Jump to content

[HELP] How to patch DSDT/SSDT for Lenovo Y410p, How to fix some problems


JSolorzano
 Share

Recommended Posts

Hello, i'm new at hackintoshing so i need help to patch my SSDT/DSDT files, can anyone help me?, i have installed OS X Yosemite on my Lenovo Y410p, i've used clover as bootloader, and was using Maciasl but don't really understand how to patch my files... so, could you please help me?
 
 

And also was looking for help because there are somethings that doesn't work on my lap, here's a list:
- Ethernet
- Audio
- External mouse
- Brightness control
- A bit of lacking with the graphics
- Bluetooth
- USB 3.0
 
Here are my lap specs:
Lenovo Y410p
CPU: Intel® Core™ i7-4700MQ/Chipset Intel Lynx Point HM86
Graphics: NVIDIA® GeForce® GT 755M/ 1366 x 768 / Intel HD Graphics 4600
Intel Centrino 2230 Wireless-N

Link to comment
Share on other sites

  • Administrators

Use Terminal command lspci -nn (need lspcidrv kext installed and loaded) to post us your exact system specs. Difficult to know what audio, Bluetooth or LAN hardware you have otherwise.
 

  • Intel wireless cards are not supported so you'll have to replace your card by another model or use a USB dongle.
  • USB3.0 ports are usually working once you add the generic USB3.0 kext. Alternatively, some systems just require the AppleHPET kext to be removed (it's known to affect USB3 functionality).
  • Bluetooth may require a patch, depending on the hardware or it may be fixed with AppleHPET removal.
  • Mobile Intel HD4600 is not natively supported by OS X (only the desktop version is) so you have to do some patching to obtain full graphics acceleration. There's a good thread about it on InsanelyMac forum or you can refer to existing Dell threads here on that same matter. You can start with my guide for the Latitude E6440 for instance.
Link to comment
Share on other sites

 

Use Terminal command lspci -nn (need lspcidrv kext installed and loaded) to post us your exact system specs. Difficult to know what audio, Bluettoth or LAN hardware you have otherwise.

 

Hello Hervé, i've tried to install lspci with kext utility, and it says that it already installed lspci, but after reboot it and run the command in the terminal it says command not found...

 

Also tried to load it after install using " sudo kextload /System/Library/Extensions/lspcidrv.kext " and then run the command, but the same mesage appears

Link to comment
Share on other sites

  • Administrators

Strange that your DCPIManager window reports a Xeon CPU and a desktop Intel HD4600 GPU (8086:0412), unless you're injecting that through Clover of course. No sign of the nVidia discrete card either (maybe you've disabled it).
 
You graphics lagging will be due to the fact that Yosemite does not natively support the mobile version of Intel's HD4600 GPU. As such, you need to patch the kexts/FrameBuffer to handle it. The process is described in the Dell Latitude E6440 guide I linked in my 1st response to you. Brightness control is directly related to the fact that you don't have graphics acceleration at the moment.
 
For audio, what are you using? If nothing specific at the moment, try a recent VoodooHDA (v2.8.4 for instance)/AppleHDADisabler kext set and see how it goes.
VoodooHDA.kext.zip
 
For Bluetooth, check the USB section of your SysProfiler. If the Bluetooth controller appears, you should be able to get that Intel module working (but only the bluetooth part, the wireless part is a definite no).
 
External mouse + USB3.0 are clearly linked. Does your laptop have USB3.0 ports only or are any USB2.0 at all? USB2.0 ports should work OOB. Try the USB3.0 generic kext.
 
For the Atheros Qualcomm QCA8171, I think the ALX kext should work. It certainly seems to apply to that card according to the listed target PCI ids.
ALXEthernet.kext.zip
 
You should also consult this IM thread; it's about the Y510p model, but I'm sure there are common features and things to learn from it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...