Jump to content

Dell Latitude 3340 Haswell


Allen_N
 Share

Recommended Posts

I failed utterly to get Yosemite installed on this machine as it would always give me an error "IOUSB Family failed to enumerate USB device" and get stuck

 

I managed to get Mavericks onto it with the PM patch on the kernel and in safe boot to extract the dsdt.

 

What works:

 

Graphics - HD4400 (laggy in safe boot)

SATA

Keyboard.

 

What Does not work

 

USB (machine has only USB 3.0 ports but USB does not even show in system profiler. USB 2.0 drives or mice do not work.

Trackpad

Webcam - (USB device)

Ethernet (intel 825xx) kext is available.

WIFI - It a M.2 NGFF card. I will wait until I get the other stuff working before I takle this.

 

 

I have got the errors on the DSDT down from 15 to 4 after applying HD4400, USB and other generic Haswell patches.

 

The errors are all "syntax error parseop_integer expecting ","

 

Does anyone know how to go about solving these?

 

Thanks

Patched DSDT 3340.zip

Link to comment
Share on other sites

  • Moderators

Can you send an unpatched DSDT?

Even better if you could follow the linux dump from here. You could use Ubuntu too.

Attach all the files DSDT/SSDT/etc...

Also list the system's specs. Use DPCIManager and get snapshot of PCI list.

Link to comment
Share on other sites

  • Administrators

Your DSDT errors are due to syntax errors. It could be that the editor you've used has smart quotes activated, in which case, disable that from the System PrefPane to avoid such issues with compilation. But, you could also have a missing or misplaced comma/bracket/quote character. You need to backtrace the errors with provided line numbers.

 

Post your raw DSDT and we'll have a look.

Link to comment
Share on other sites

Thanks guys, The raw DSDT has 15 errors before any patching is done

 

I am unable to get a PCI snapshot as I can only use the keyboard as an input device and cannot click the button, (No trackpad, No USB mice)

 

I got the APCI dump from DPCIManager.

 

Here they are.

Archive.zip

Link to comment
Share on other sites

Thanx J Lo,

 

Lots of progress made!!

 

What Works!!

 

Graphics Incl HDMI and mini DP (dsdt patch and IGplatformID injection)

Keyboard

USB3 - disconnects drives on sleep

Webcam

SLEEP and Power Management

Ethernet (cosmetic dsdt patch and AppleIntelE1000

 

What doest Work:

 

Trackpad (Tried the cypress fork of VoodooPS2Controller)

O2 Micro Card Reader (Tried patching the plist of the USB card reader. It seems to be PCI so this had no effect (Ven1217 Dev8520)

Audio - No Tried the dsdt patch and the AppleHDA here (https://osxlatitude.com/index.php?/topic/5857-e6540) and also VoodooHDA 10.8.5

Brightness control - No - Tried patching the dsdt

 

Also I had trouble trying to generate a ssdt for my machine. ssdtGen.sh doesn't work on haswell machines. The newer version in App form opened and immediately closed after.

 

Here is the latest iteration of the dsdt that I have made edits to.

 

I am using MacBookAir6,2 SMBIOS.

 

 

DSDT.zip

Link to comment
Share on other sites

  • Moderators

Try kexts from my E7440 guide.

Can you confirm you have Cypress touchpad and not Alps? Alps is included in my bootpack.

The patched AppleHDA by Joe82 for ALC292 should work too but will require EADPfix to fix wake from sleep issue.

O2 Micro card reader can be fix with a DSDT patch which was added from DSDT I patched for you but perhaps on the wrong location. Will have to see your IORegistry to determine that. 

Brightness control is through Fn+F3 (ScrollLock) and Fn+Insert (Pause)

Link to comment
Share on other sites

 Share

×
×
  • Create New...