Jump to content
PayPal donations: [email protected] ×
mitodna

Install OS X on E7240

Recommended Posts

Hi Lackey,

 

My partition is like this:

/dev/disk0

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *256.1 GB   disk0

   1:                        EFI EFI                     209.7 MB   disk0s1

   2:                  Apple_HFS Macintosh HD            255.2 GB   disk0s2

   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

 

Attached is my EFI partition

 

EFI.zip

Share this post


Link to post
Share on other sites

I don't see anything wrong with your partition layout.
 
I also don't see anything obviously wrong with your EFI partition and config.plist. Where did you get HFSPlus.efi? From Clover Configurator? If Clover cannot see Macintosh HD, how did you retrieve this partition map? Do you have another OSX partition, or are you switching back and forth between Clover and Chameleon?
 
Next thing I'd check is if your BIOS is configured correctly.
 
Walk me through the steps you're using to install Clover; also, please provide my a screenshot of the the options you chose in the Clover installer.

Share this post


Link to post
Share on other sites

thanks. my update in post 1, in summary, i manage to install Clover r3253
 
please note i didn't patch dsdt, i manage to boot, i copied the config.plist from the USB i create to the /Volumes/EFI
 
these are the things, I still need some advice
1. slow mouse, but two finger scrolling works, by press 1 finger and scroll 1 finger
2. USB 3.0 no longer works 
3. touch screen no longer works
4. I remember at one time I did saw the battery status, not sure what I did that time
5. how do I fix the QE/CI on this please?
6. how do I find out whatelse is not working? may be like sd card, audio, video output, ethernet
7. how do I check if the CPU is working fine?
 
DW1550 wifi is working
 
Really appreciate some hints/guide on this. Thanks.

Share this post


Link to post
Share on other sites

Try the various Azul framebuffer layout-id values to get full graphics acceleration. You can find value details at RampageDev's blog in his Intel HD guide. When you specify the ig-layout-id in Clover (or in Chameleon to that effect), bear in mind that you enter the values in reverse order.

 

For instance for ig-layout-id 0x0a260006, you'd enter: 0600260A.

Share this post


Link to post
Share on other sites

did manage to almost fix the graphics using FakePCCID, but there is menu glitches, did the 9mb frame buffer thing, but it is not working
 
i don't have dsdt patching
 
this laptop only have 3 usb3, usb3 not working though
touch screen not working anymore, strange
 
attached is the clover.zip
 
any advices? thanks

EFI.zip

Share this post


Link to post
Share on other sites

Install these from 10.10 to /System/Library/Extensions with kextwizard

AppleHDA_ALC292
DisableTurboBoostBattery
FakePCIID_HD4600_HD4400
FakePCIID
IOAHCISerialATAPI_Injector
 
Install this to /S/L/E to fix audio after sleep issue
Replace the Config with attached and add the DSDT.aml to ACPI/Patched
For SSDT, use ssdtprGen.sh found in my Yosemite Guide.
 

 

 

E7x40.zip

  • Like 2

Share this post


Link to post
Share on other sites

Jake, you are awesome,

 

also many thanks all that commented on this thread, really a leap forward, now i manage to boot it

 

to update, i am on 10.10.5

 

1. touch screen back to working

2. no bluetooth, my card is DW1550

3. i am using WifiInjector.kext, not sure what it does, but wifi is working

4. i can't control brightness, I remember at one time it was work, i suspect it is the VoodooPS2Controller.kext

5. not sure why, there is not sound output, there is volume control thought, i not sure if this is hardware issue

6. there is battery percentage as well :)

 

edit: sound apparently is apparently working after second time reboot

 

do you need to install VoodooPS2Controller.kext or put in Clover 10.10 folder?

 

many thanks

Share this post


Link to post
Share on other sites

VoodooPS2Controller should be in /EFI/Clover/Kexts/10.10. Without it, you won't have keyboard and mouse capability. To control brightness, use

Fn+F3 = dim

Fn+Insert = Bright

Your Bluetooth should be working with a firmware uploader here. Try version 2.8.5. Install to /S/L/E

  • Like 1

Share this post


Link to post
Share on other sites

VoodooPS2Controller should be in /EFI/Clover/Kexts/10.10. Without it, you won't have keyboard and mouse capability. To control brightness, use

Fn+F3 = dim

Fn+Insert = Bright

Your Bluetooth should be working with a firmware uploader here. Try version 2.8.5. Install to /S/L/E

 

thank you, the brightness key works, can you tell, if I could remap this please?

 

i will try out the bluetooth soon, thanks

 

by the way, i did try audio after sleep, which is not working, just to let you know, thanks

Share this post


Link to post
Share on other sites

you probably could remap the keys through DSDT but I'm not skilled to do that.

for audio after sleep, did you do this?

 

Install this to /S/L/E to fix audio after sleep issue

Share this post


Link to post
Share on other sites

×
×
  • Create New...