Jump to content

E6400 Yosemite Problem


Recommended Posts

My Latitude E6400 currently has OS X 10.5 on it, I need to upgrade to 10.10 so I can run XCode. I've been trying to follow "krzysztofc10"'s tutorial on installing Yosemite on the E6400, I followed the tutorial perfectly, I have the same specs except the 2.13Ghz CPU. 


The USB Installer says it installs correctly, if I'm correct I'm meant to use GUID Partition Table with Mac OS X Journalled formatting.


However when I turn the laptop off, then go into the boot menu and select the USB nothing loads. There's just the black screen with a white underscore flashing.


If I load Chameleon off a CD I have then try and load the USB from there it says "Cannot find mach_kernel" and there's no mach_kernel in my Yosemite's System/Library/Kernel either. I tried installing Chameleon to the USB to bypass the "Cannot find mach_kernel" problem but then I'd get a problem where it would load the kext's the just go black and reboot the laptop.


So I cannot boot the installer. Thanks for any help! 


EDIT Solved:


1) Install Yosemite using this guys tutorial (Disable Charger, Speedstep, Multicore if youre having problems)

2) Once Yosemite installs, go back into the Yosemite setup

3) Plug a USB, go to WIndow > Disk Utility in the setup then format the usb to Mac OS X Journaled

4) Download the "Extra.zip" folder from the guys tutorial in step 1, extract it and edit the SMBIOS file to match your CPU Speed

5) Now on another PC/Mac insert your USB. If you're on WIndows, install HFS Windows  then reboot windows so you can view the USB you created in step 3

6) Put the extra folder on that USB

7) Go back to your laptop and open terminal

8) Use the terminal command to copy your extra folder from your USB to the root of your Yosemite install (look at terminal tutorials, i used ditto command)

9) Switch off laptop and boot into Chameleon

10) Launch Yosemite with -v -f and everything will work it's magic


So in short, I had to use this method to get the kexts onto my Yosemite HDD


You can renable speedstep/multicore/charger after install

Link to comment
Share on other sites

Thanks for the fast response! I tried the  Vanilla_kernel_10.10-10.10.1.zip but I still got the black screen and reboot when it tried to loadthis kext:
I verified that I definitely had 10.10 and not 10.10.5 or something using this tutorial so I am still not sure what I am doing wrong. I have attatched my SMBIOS and org.chameleon.Boot.plist as I suspect I may have something wrong in those files. As well as that I'm using a 32GB USB as that's the only large USB i have. Could that be the problem?
Thanks for any more help. 
SMBIOS.plist : https://dl.dropboxusercontent.com/u/31400064/mac/smbios.plist
Org.chameleon.Boot.plist : https://dl.dropboxusercontent.com/u/31400064/mac/org.chameleon.Boot.plist

Link to comment
Share on other sites

  • Administrators

It sounds like you may not be using an adequate version of Chameleon. For Yosemite, I can vouch for older versions such as r2395, 2401 or 2468 for instance. However, you may want to switch to the Enoch branch that has the attention of developers these days. Version r2795 works perfectly for me. Enoch includes some on-the-fly kernel patches and/or kext loading mechanism which are very interesting.

Link to comment
Share on other sites

Thanks for the suggestions. Running Chameleon r2395 on a USB, I couldn't detect my USB Installer so I put the Mac installer on another HDD Partition. Tried loading it with -v -f and that allowed me to load all the kexts and brings up a higher resolution screen with black and white text!

However, after loading texts, I was getting "RTC: Only Single RAM bank (128 bytes)"  on the new screen


I managed to bypass that using boot arguments 


-v pci=acpi -f npci=0x2000 DSDT=No busratio=10


And now when the laptop is charging its stuck on


ACPIBatteryManager: Using ACPI regular battery information method _BIF


and while off charge it gets stuck at


"ACPIBatteryM"  :-(


EDIT: Somehow managed to load the yosemite installer and install Yosemite with Chameleon r2391 and only -f -v, but now I get the same errors I did on the installer on the Yosemite HDD. 


EDIT 2: It either gets stuck on RTC: Only Single Ram Bank (128 bytes) or mbinit:done

Link to comment
Share on other sites

Still can't get into installer/yosemite and I've overwritten my previous OS X 10.5 installation to install Yosemite. Think I'm locked out haha



EDIT: I got pretty far in to the boot by disabling multi core and speedstep in the BIOS. But it now is stuck at "Checking catalog file" but the HDD light has been on for the past 40 min.

Link to comment
Share on other sites

  • Create New...