Jump to content

E6430s KP with Clover USB


ssprod
 Share

Recommended Posts

Greetings.. just acquired a refurb E6430s (Lo Res) from Dell Refurb. Hoping that this guide (https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-el-capitan-clover-guide/) with the E6430 Boot Pack would work with the USB, but I'm getting a KP and reboot. I noticed that the the Guides boot pack is a Hi Res.. are any edits required to get me to boot via the USB? Thanks so much! ssprod

post-44-0-66495900-1454369226_thumb.jpg

Link to comment
Share on other sites

  • Replies 27
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Moderators

Googling the system specs and determine that the s model can either have an IvyBridge with HD4000 or SandyBridge with HD3000.

List your system's spec to determine which bootpack is best fitted for your system.

 

If it's an IvyBridge, you could try the E6230 bootpack with lower resolution.

Link to comment
Share on other sites

Thanks Jake.. i5-3320M CPU Ivy Bridge w/HD4000. Will try E6230 bootpack. 

 

----->Update:Installed 10.11.2 with the E6230 Bootpack, however major graphic glitches are resulting. Is it reccomended that I extract a native DSDT from this E6430s? Thanks. 

Link to comment
Share on other sites

  • Administrators

Typical DualLink parameter issue... HiRes DSDT will have IGPU DualLink parameter set to 1; you need this set to 0 on a LoRes machine. Adjust the DSDT (you may use the related boot option meantime).

 
In your DSDT, lookup for the IGPU device (or whatever it's called) at address 00020000:

           Method (_DSM, 4, NotSerialized)
           {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03
                    })
                }
                Return (Package (0x0A)
                {
                    "AAPL00,DualLink", 
                    Buffer (0x04)
                    {
                         0x00, 0x00, 0x00, 0x00       /* adjust according to screen res */
                    }, 
                    "device-id", 
                    Buffer (0x04)
                    {
                         0x26, 0x01, 0x00, 0x00       /* Intel HD 3000 */
                    }, 
                    "model", 
                    Buffer (0x18)
                    {
                        "Intel HD Graphics 3000"
                    }, 
                    "AAPL,snb-platform-id", 
                    Buffer (0x04)
                    {
                         0x00, 0x00, 0x01, 0x00       /* Sandy Bridge framebuffer */
                    }, 
                    "hda-gfx", 
                    Buffer (0x0A)
                    {
                        "onboard-1"
                    }
                })
            }
Link to comment
Share on other sites

  • Moderators

@ssprod

 

The DSDT I uploaded is for singleLink 1366x768, can you confirm you have that resolution?

Also you need to use the Config from E6230, confirm that also.

Lastly, downgrade your BIOS to A03, and then install A12. 

Link to comment
Share on other sites

 Share


×
×
  • Create New...