Jump to content

El Capitan E5430


savage24x
 Share

Recommended Posts

Currently have my El Capitan install working with HD4000 1536MB, DW1520 Wi-Fi, and that's about it. Sleep works, two-finger scrolling works. I tried the Yosemite HDA 92HD93 (AppleHDAIDT.kext) and config.plist mod for the audio with no dice. Bluetooth is also not working, due to the USB changes inside El Capitan. I attached my CLOVER for anybody that wants to get their El Cap running. Any ideas for audio and bluetooth?

CLOVER_E5430_1011.zip

Link to comment
Share on other sites

Derp, never clicked "Attach this file." I knew someone was hiding that audio kext from me. The Broadcom(?) 380 is the bluetooth module.

 

EDIT: No audio. Removed the Yosemite AppleHDAIDT kext and installed El Cap HDAIDT. Two files in /S/L/E, AppleHDA and AppleHDAIDT. Do I remove AppleHDA? Also, backlight adjustment stopped working after installing HDAIDT and touching the /S/L/E folder.

 

Edit2: following the guide you made, replacing my other kexts with the ones in E6230 for 1366x768.

Link to comment
Share on other sites

  • Moderators

Replace Config with this. I added the correct audio patches. Also remove AppleHDAIDT, that's for 92HD90bxx, install instead AppleHDA_IDT for Exx30 (92HD93) from the same link above.

 

For Bluetooth, you'll need to add you Ven/Dev ID to

/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Contents/Info.plist

 

Use macKextlight, drag IOBluetoothFamily.kext to the Window on the left

bluetooth380.png

 

Do a search for BroadcomUSBBluetooth

 

Paste this between and with the Prod/Ven ID of your device

 

Broadcom380FamilyUSBBluetoothHCIController

CFBundleIdentifier

com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport

IOClass

BroadcomBluetoothHostControllerUSBTransport

IOProviderClass

IOUSBHostDevice

idProduct

33175

idVendor

16700

 

Click save  and repair permission.

config.plist.zip

Link to comment
Share on other sites

Everything is working, except bluetooth. First thing I did was the patch with macKextLight, then rebooted. Bluetooth worked. Then, I replaced the config.plist with the one you created for me. I lost bluetooth. HDA_IDT works great. Everything is working except bluetooth. I attached my CLOVER folder. That folder contains your config.plist with the patches. I have also attached my working config.plist that bluetooth works with. Only difference is the patches.

 

Ever since I ran:

sudo pmset hibernatemode 0
sudo rm -f /var/vm/sleepimage
sudo pmset hibernatefile /dev/null

I have not been able to wake my laptop from sleep. Just a black screen with a spinning color wheel.

CLOVER_savage24x.zip

config.plist.zip

Link to comment
Share on other sites

  • Administrators

instead of using 0 as  an integer, you use what you had before normally apple uses 3 for laptops.

 so it would go like this sudo pmset hibernatemode 3.

there are mentions of other hibernate modes like 21 or 57 and a bunch more i cant recall it varies by machine and i think you need native nvram plus aptiofix2. more then that i cant help you with but i'm sure you might turn up something if you search. most of that documentation was on the defunct site projectosx.

Link to comment
Share on other sites

 Share

×
×
  • Create New...