Jump to content

Inspiron 3148 El Capitan/Yosemite


Recommended Posts

Alright! I was going to reply a long time ago, but I have done much with this device since then...


I clean-installed macOS Sierra, and this is the status:


--Sierra 10.12.6--


DW1830 802.11ac + BT4.1 (recognized as AirPort Extreme with FakePCIID)

ELAN touchscreen (working with FakePCIID_XHCIMux.kext and EHC1>EH01 patch to DSDT)

Webcam (same as touchscreen)


Not working:

Sound (tried both Lilu + AppleALC and the CodecCommander solution)

Power button

Brightness keys



SD Card Reader



I will look into fixing the power and brightness buttons. At the moment, they seem to generate ACPI events, so I will see if I can debug it using RehabMan's VoodooPS2 and ACPIDebug kernel extensions.


There is something odd, though. I was testing buttons on my keyboard, and I found that I could use Fn+B and Fn+S to control the screen backlight. It's almost more convenient than the real brightness keys!


I don't know what I would do without RehabMan... All of my devices are working because of him!

Link to comment
Share on other sites

  • Replies 31
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Alright! I have made some progress since my last post.


Sound is now working! I used a combination of DSDT patches and a dummy HDA kext, all generated by AppleHDA Patcher, to make it work. Thanks to Micky and Mirone...


Brightness control is now working! Originally, I adjusted brightness by mapping such keys to my Function keys in Karabiner. I decided to get the actual keys working and investigate. I edited the EC query in the DSDT to output the brightness key codes to my keyboard driver (from EMlyDinEsH's Smart Touchpad driver) I created a patch for it, and it is attached to this post.


I'll use the same method to get the power button working. I know its query name, but I don't know the PS2 key code that corresponds to the power button in the Smart Touchpad driver, so I can't make a patch... Do you know the co', Mr. Lo:-P


EDIT: The power button works. The combination to activate the shutdown dialogue is Ctrl + Power. I found this post by RehabMan where a user was trying to fix the same problem. Apple apparently intended this for its products.



Anyway, I also tested HDMI. The video output works, but audio still doesn't. I'll try the kext patches that Jake provided earlier before I try the FakePCIID solution.


Link to comment
Share on other sites

Ok! Will do. Also, do you have the latest version of IOReg? I only find really old versions when I search to download them.


Before I can do that, though—I re-extracted my ACPI tables and am running into a problem with compilation. A method(?) called MDBG is the culprit. I can't determine the exact issue because it has an "unknown exception ID." I tried removing the given line, and then looked at removing all sections referring to MDBG and anything related, but other methods depended on declarations made from MDBG, causing even more errors.


I am running the latest version of iASL (10 Nov 2017), compiled from Rehab's fork. Apparently the compiler didn't notice the problem last time, but now that I open my old tables with the latest iASL, there it is.


Thank you :)


Link to comment
Share on other sites

Thanks for the download :-D


OK... I guess it isn't the best idea to update whenever one can. I happen to have that version of MaciASL on my desktop. I will send it over to my Dell.


Thanks again!


EDIT: I have something else to ask... The Inspiron sometimes reboots and does a self-test with loud beeping and color bars. How may I disable this? It is terribly annoying.

Link to comment
Share on other sites

ePSA is built into the BIOS, it will usually execute selecting F12 during boot. If it auto execute, it could be it detects hardware failure.

If you let it completes, does it show anything failed?


Ah, ok. I let it complete a couple times when it first started auto-executing, and to my memory, nothing was wrong. I'll let it complete the next time I see it and report back here...



could be you need to reseat something inside the machine like ram or wlan card.


I have removed both before, and reseated them just yesterday, in fact. I'll intently reseat both, then wait for the ePSA test and see what happens ;)


I want to say that the test has been auto-executing ever since I replaced the OEM DW1708 with a DW1830... I feel pretty sure of that, actually. Maybe I'll try (1) reseating everything, (2) completing the ePSA and seeing the results, and it nothing is found, (3) swapping the DW1708 back in and rebooting a few times.


This is gonna be fun  8-)  Thank you all!

Link to comment
Share on other sites

All right, here we go:


1. I reseated the memory and wireless card. I rebooted the machine a few times, cycling Clover>Reboot>Clover and so on. The ePSA test had not been executed, so I tried a sure-fire way to get it started—having it fall asleep and reboot (neither sleep nor shutdown work properly at this point). Sure enough, the test came up. This method worked 4 out of the 5 times that I had tried it.


2. I let the test run and it found nothing wrong. It suggested performing extra 30min-long memory tests, but I declined. The memory was fine at that point, according to the test.


3. I swapped my DW1708 for the DW1830 and booted again. I tried the sleep method again three times to trigger the test and it appeared each time.


Does this have anything to do with sleep in macOS? This has been happening before I upgraded to High Sierra, though, but not as frequently because sleep and shutdown worked properly then... :?




Speaking of sleep and power, after I upgraded to High Sierra, I was able to get those and brightness adjustment working. It all stopped working a few days later. I don't think I took any system-critical updates right before that, and App Store doesn't tell me otherwise. I recompiled and patched my ACPI tables in response before eventually reseating all the hardware just now. It had no effect, obviously... 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...