Jump to content

Keyboard and trackpad not working in installer


antialias
 Share

Recommended Posts

[sOLVED]

 

Hello guys,

 

I have Dell Latitude e5530, i5 Ivy Bridge, Intel HD4000, and am trying to install El Capitan with Clover, but I am stuck at installer screen. Keyboard and trackpad not working. I tried with all possible kexts in USB/EFI/Clover/kexts/Other with no luck (I tried with 10.11 folder as well).

 

External usb mouse doesn't work either.

 

What could be wrong?

 

I've been hackintoshing for 6 years and I never had this problem before (both desktops and laptops).

 

And clues?

 

Cheers

Link to comment
Share on other sites

  • Moderators

Is there a bootpack you're using?

or you're creating your own?

Which version of El Capitan are you installing? there's a known issue with Voodoops2Controller on 10.11.4 and needs a specific version to work. 

See my Clover guide for some hints.

Link to comment
Share on other sites

Thank you guys. I've solved it sort of.

 

Voodoo didn't work at all, but I've found ApplePS2SmartTouchPad.kext and it works. I didn't use any bootpack because I couldn't find any for e5530 vPRO. 

 

I have installed El Capitan 10.11.4, dual booting with Windows 10 on the same SSD.

 

Only one USB port (USB2) works, the one on the rear (USB2?) doesn't work, and USB3 on the left side doesn't work either.

 

QE/CI fully working.

 

So, I have to see what audio codec is on my laptop. 

 

If you have some good links  I will appreciate it.

 

Cheers,

Link to comment
Share on other sites

  • Moderators

You could use the E6430 bootpack here. I could help you patch you DSDT/SSDT if you could upload them here.
Boot to Clover, hit F4. Then boot to OS X, compress /EFI/Clover/ACPI/Origin and upload it here.

  • Like 1
Link to comment
Share on other sites

Here we go. Attached:
 
1. Original AppleHDA.kext (untouched from my El Capitan 10.11.4)
2. codec_dump.txt (extracted from Linux)
3. config.plist
4. ioreg
5. Screenshots from DPCI Manager
6. Folder with both origin DSDT/SSDT and disassembled DSDT/SSDT
 
https://drive.google.com/file/d/0B_i-OOva-nWGVm12RmdJemtLMmc/view?usp=sharing
 
 
I hope it helps :)
 
Thanks in advance

Link to comment
Share on other sites

  • Moderators

Here, try these. Make a backup of Config first.
Copy this to /Library/Extensions. Leave the vanilla AppleHDA as is.
Note: Ignore warning/error messages and click OK, then run commands below.
 
Repair permission and rebuild cache. Run command from terminal
      sudo chmod -Rf 755 /L*/E*
      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo kextcache -Boot -U /
 
Expected to work with these files:
Sound, SD Card reader, USB 3.0, HDMI Video/Sound

antialias_E5530.zip

Link to comment
Share on other sites

Hi Jake LO,

 

I followed your guide, copied your AppleHDA_ITD.kext to /Library/Extensions, run commands in terminal, I left vanilla AppleHDA.kext untouched in /S/L/E, copied your DSDT.aml to /EFI/EFI/Clover/ACPI/Patched and finally replaced my config.plist with yours.

 

Here is the status:

 

1. All USB ports work :)

 

2. Brightness control works :)

 

3. SD Card reader couldn't check, I don't have a spare SD card

 

4. When I booted I got terrible artefacts on the screen so I was forced to disable your AppleIntelFramebuffer patches in the config.plist to get rid of the artefacts. I've noticed in your comment there it's for 1600x900 resolution. I have 1920x1080 resolution.

 

5. Still no sound device detected.

 

6. I run kextstat | grep -v com.apple and your AppleHDA_ITDkext was not loaded

 

Cheers :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...