Jump to content
PayPal donations: [email protected] ×
error10

[SOLVED] Sierra on E6530 kernel panic in IOAcceleratorFamily2: Resource freed while display pipe 0 has pointer to it

Recommended Posts

I'm doing a fresh installation on a Dell Latitude E6530, Core i5-3320M, 15.6" HD4000 1920x1080, 16GB RAM, 500GB SSD.

 

Not seeing any Sierra guides, I followed along with this El Capitan thread, using the E6430 bootpack as that seemed closest, and updating the VoodooPS2Keyboard.kext. All went well during the installation and first boot, but after I installed Clover to the SSD and rebooted, this was the result:

 

post-98953-0-63812200-1475303533_thumb.jpg

 

There is a larger and more readable version of this image.

 

This occurs whether I try booting from the hard drive or the USB install media.

 

It boots up in safe mode, but the video is so slow as to be nearly unusable.

 

I've tried a couple of things to try to isolate the problem:

 

I removed the generated ACPI/patched/ssdt.aml, which had no effect.

 

I tried to remove the Boot Graphics Glitch - 10.11 patch from config.plist. This allowed the system to boot, but the graphical glitches were there. It looked like sections of random snow all over the screen. I suspect that this patch needs to be updated for Sierra. (I then added it back in.)

 

At this point I am open to suggestions.

efi.zip

Share this post


Link to post
Share on other sites

make sure you're on BIOS version A12 or below. If you have something higher, you need to downgrade to A03 and then up to A12. 

For Sierra boot glitch, just change to this

 

find 

01000075 25

replace

010000EB 25

Share this post


Link to post
Share on other sites

This patch lets me boot, but it doesn't get rid of the graphical glitches. I changed the existing patch in Clover's config.plist to read like this:
 

            <dict>
                <key>Comment</key>
                <string>Boot Graphics Glitch - 10.11</string>
                <key>Find</key>
                <data>
                AQAAdRc=
                </data>
                <key>Name</key>
                <string>IOGraphicsFamily</string>
                <key>Replace</key>
                <data>
                AQAA6xc=
                </data>
            </dict>

My BIOS is currently on A17. I haven't yet tried to downgrade it as that will take some more time. And I'm also concerned it might mess me up trying to run Windows 10 later, or maybe have other side effects.

post-98953-0-64638300-1475355786_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...