Jump to content

[Help] Optiplex 3010


Borgo1971
 Share

Recommended Posts

Hello. I'm trying to fix two issues (maybe, one related with the other) on my Dell Optiplex 3010 SFF hackintosh with OS X 10.11.6. The hardware is this: <http://tinyurl.com/htbepjk>,with optional ATI Radeon HD 5450. Here are HWinfo: <https://dl.dropboxusercontent.com/u/4228522/OPTIPLEX-3010-W.HTM>

1. Random freeze: randomly, the computer freezes, sometime restarting alone, but mostly it becomes unresponsive with corrupted screen; even in this case, the only solution is to restart it holding power button. The issue happens randomly, and I wasn't abel to invoke it voluntary, even with heavy workload. More then one time, it happened at return from stop, but not only. I didn't have any problems (until now) when the computer is booted with windows 10 (were I did many diagnostic, even the DELL online extend and stress test).

2. USB ports not working: the front USB and the two in the middle of the rear ports, won't function in OS X, but they function in Windows and also in Clover. I fond that replacing DSDT.aml in EFI/CLOVER/ACPI/patched with the one you bundles in post #25, makes work the USB ports, but creates problems in the GUI, with unresponsive mouse pointer, slow screen refresh and some artifacts.

My principal goal is to fix the first issue (it happened even 3 times in an hour, but other times, it can pass an entry day without having any problem), but as it happens so randomly, I guess it's easier try to fix USB issue, hoping that this will fix both issues.

I've good IT skill, but I'm new to hackintosh world, can someone help me?!

I've attached System Profiler screenshot with USB panel with my DSDT.aml (computer normal working, but not USB), and another with ioncatana's DSDT.aml (USB seems normal working, but computer is unresponsive)

post-102705-0-78764300-1481734719_thumb.png

post-102705-0-80967800-1481734727_thumb.png

Link to comment
Share on other sites

Oh, great! Here in attachment is my DSDT.aml.

 

And at this link, you could download my entry Clover folder (from EFI partition).

https://dl.dropboxusercontent.com/u/4228522/CLOVER.zip

 

Tomorrow I'm away all day, and I guess Friday too, so I don't know if I can reply at all... sure I cant try anything on my hackintosh.

 

Thanks again for your for the interest.

Link to comment
Share on other sites

BIOS A16, usual settings for OS X UEFI (legacy rom enabled, Vt-d disabled, serial disabled, if available DVMT prealloc to 96MB), latest Clover bootloader, manual install USB creation, booted perfectly fine & installed OK (10.11.6)

Just had to replace stock 2nd gen CPU with i3-3225 from ebay and use cheap nVidia 210

 

NO DSDT needed on this hardware

Used other files from here

 

VoodooHDA installs/works fine but had to install it THREE times, two KP, 3rd installed ok (but use USB peakers anyway), updated to latest Security Update 2016-002 with no issue

 

Perfect hack for under £100 all in!

 

sebus

Link to comment
Share on other sites

 Share

×
×
  • Create New...