Jump to content
donaldant

[Successful] Sierra E6330 action reporting

Recommended Posts

Post #16 is patched from your Origin folder. Could be your SSDT-USB is incorrect.

Remove it and restore the AppleUSBXHCIPCI patch in your config.plist and see if it makes a difference.

Share this post


Link to post
Share on other sites

Jake Lo, this is a different E6330, the one you patched for me before was an i5 vPro CPU and that one works perfect.  This is an i7 CPU.  Thanks!

Share this post


Link to post
Share on other sites

shouldn't make a difference, you just need to generate new SSDT.aml for different CPU. 

I'll go ahead and patch it anyway but will need to know the display resolution.

 

Nevermind, included both. Just rename the one that's correct for you.

 

E6330_i7_A11.zip

Share this post


Link to post
Share on other sites

Jake Lo,

I generated the new SSDT for this CPU and also created the new ssdt-usb.  This one has a different usb port number for eSata/usb combo port than my other E6330.  Everything seems to work now.  The touchpad is still a little unresponsive at times.  This touchpad works fine with Windows 10. On the other hand, the other E6330's touchpad works perfectly fine in Sierra but is unusable in Windows 10.

 

Thank you very much!

Share this post


Link to post
Share on other sites

Hello,

I have installed Sierra 10.12.5 on my E6330 (Bios A11, I5-3340M, 4GB RAM, display 1366x768), wifi Dell DW1510, Bluetooth BCM92070MD) by following the installation guide of this site.

Working: Ethernet, Wifi, Bluetooth, audio, USB 3.0. Not Working: VGA (external monitor),, TouchPad erratic. 

 

Should I keep Kexts in EFI Clover folder or move them to SLE folder?

Could you patch original DSDT created from F4 Clover?and anything to add to my config? Thank a lot.

 

Attached ACPI,config.plist and Kexts

ACPI&config.zip

Share this post


Link to post
Share on other sites

See here to patch VGA for HD4000. You could add it to Clover Config kextToPatch.

No need to repatch DSDT if everything else is working. DSDT was for BIOS A11 as yours.

Share this post


Link to post
Share on other sites

Hi Jake,

 

I load Sierra 10.12.5 on my E6330 (Bios A11, 8GB RAM, 1366x768, wifi Dell DW1520) by following the your guide.

 

Everything looks fine, except sound, under system information/audio show Intel High Definition Audio. But there is no device under system preference /sound. 

 

The clover is attached.

 

Thanks

 

CLOVER.zip

 

 

Share this post


Link to post
Share on other sites

You seem to be mixing 2 different bootpacks in there. Why not just use the Sierra bootpack here, updated for 10.12.4 and up.

You have both AppleHDA_IDT.kext and AppleHDA_IDT92HD93.kext doing the same thing. 

Use either one but not both and make sure AppleHDA in /S/L/E is vanilla. Hervé's guide is Chameleon and also has a patched AppleHDA since it can't be patch on the fly with Clover Config. So if you had installed that, it'll still work. You just had to repair permission and rebuild cache.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...