Jump to content

[Successful] Sierra E6330 action reporting


Recommended Posts



I challenged the osx project for the past three weeks. (That was very difficult and tough).

As a result, I was able to confirm the operation it.


First of all thanks to the osx project.


Special thanks:Jake Lo




I followed this installation and succeeded.



#I selected this folder.




-10.12.2 OSX



-Battery Monitor



Not Working



-D-Sub(External monitor)

-Touch Pad(Molti touch)


My E6330 specs:

Intel Core i5 (3rd Gen) 3320M / 2.6 GHz


1368 x 768 LCD

Mobile Intel QM77 Express chipset





#Sorry, not working. In my environment, a stop sign appeared during installation.

Probably, I think the contents of the EFI folder are different.




Thank you for your attention.


Link to comment
Share on other sites

  • Replies 55
  • Created
  • Last Reply

Top Posters In This Topic

  • Administrators

Although they're closely related, the Latitude 6430u and Latitude E6x30 do differ. I'm not sure their DSDT are interchangeable. You could have re-used the E6430 pack from El Capitan. Granted the pack is listed for the HiRes LCD model but this can be adjusted to fit the LoRes LCD by changing the DSDT IGPU _DSM method where you change:

  • ig-platform-id from 0x01660004 to 0x01660003
  • DualLink from 1 to 0

To be on the safe side and actually contribute towards a proper E6330 pack, maybe you could actually extract the E6330 raw tables from BIOS and post them. You can extract them by pressing F4 at the Clover menu and you'll find them in the ACPI/origin folder of your EFI partition. This old E6330 Mavericks guide has an Extra pack with a DSDT with which you could compare.


For Bluetooth and wifi, well it all depends on the hardware fitted to your E6330. Latitude E6x30 models tend to be fitted with DW380 bluetooth module and that works Ok as described in my E6230 guide. You may also install Rehabman's BrcmXXXX kexts as an alternative to the IOBluetooth PlugIn patch.


TouchPad will work perfectly with Dr Hurt's latest VoodooPS2 kexts (I can vouch for his versions 4 and 5) which are available in post #1 of his dedicated thread in R&D->Kexts subsection.


Don't use E6x20 guides as reference because these are SandyBridge models, not IvyBridge. Whilst the E6x20 and E6x30 share some hardware components (e.g.: LAN card), they're nevertheless different, especially on key components such as graphics (HD3000 vs. HD4000), audio (IDT 92HD90 vs. IDT 92HD93) or USB (2.0 only vs. 2.0/3.0).


NB: there's no support for HD4000 VGA output on these computers.

Link to comment
Share on other sites



Thank you for the advice. I tried several times based on your advice, but Wifi and MultiTouch did not work.(But Bluetooth moved.)


[My way]

1. I installed Dr Hurt 's Voodoo PS 2 kexts using Kext Wizard. Version tried both 4 and 5. As a result, the trackpad not found error has disappeared, but it is the same as before.

2. I installed Rehabman's kexts in the same way. As a result, Bluetooth can now be used, but WiFi could not be used.













Link to comment
Share on other sites

Jake Lo , Hervé Thank you for your reply.

I installed the following devices.
(My WiFi device is DW 380.)
Dr Hurt's latest VoodooPS2 kexts .post #1
Release 4/5 
I will use this weekend to investigate more.
Link to comment
Share on other sites

@donaldant any more info on the progress with your E6330? I've just acquired one which would be coming in the mail on Friday with a bad screen and also a screen replacement. Could possibly use and learn from your experience in order to get mine working as well.

Link to comment
Share on other sites

Hi Jake Lo,
I've just installed 10.12.5 with your new bootpack.  There're a few things that doesn't work such as bluetooth, camera and the usb part of the eSata/usb combo.
It seems like these usb ports that these devices connected to were not got injected.  From "System Information", they are not listed under Bluetooth, Camera or USB, also not shown in ioregExplorer either.  The right (HSP1 + SSP1) and back (HSP2 + SSP2) usb ports work fine.  Could you please help me with these!
I attached here my CLOVER folder, included my aml files from F4, and also a copy of ioreg file.  Thank you so much!
From Windows, these are the Bios Device Name/ Hardware ID.
Bluetooth - 
Camera - 

eSata/usb port -

E6330 low-res.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...