Jump to content

Dell T7500 Fan Problem


Recommended Posts

Hi all

 

Dell T7500 successfully running Sierra with one problem

I have no fans!

Darwin dumper (SMC) shows 0 fans present in the system and HWMonitor also shows no fans.

This machine was intended to be used as a render machine so obviously this is a huge issue.

I am assuming I will need DSDT patches to add the fans?

Using my windows partition and RW-Everything I have found the address of the fans (0x1B10-0x1B17)

Does anyone have any ideas or experience with this?

Many thanks

Link to post
Share on other sites
  • Administrators

Fans not being detected at OS level is not necessarily an issue; BIOS is perfectly able to control fans according to CPU T° and other elements.

 

This being said, are you using a recent FakeSMC and all its sensors PlugIns?

Link to post
Share on other sites

Thanks for the response! Unfortunately the BIOS does not spin up the fans. I have run Cinema4D renders to get the CPU temps upto 85'c and nothing kicked in so I stopped.
 
Yes, I am using current FakeSMC + Plugins
 
I did some more digging yesterday, there is no thermal control in the DSDT file and I cannot see any reference to fans in there. However, in darwin dumper DMI tables I can see all the fans as 'Cooling Device"
 
Is there any way to get the DSDT to reference DMI tables?

Link to post
Share on other sites
  • Administrators

Fan control may be in an annexe SSDT. Dump all your native ACPI tables to check this. Do you have native CPU SpeedStepping on this T7500? What graphics card do you use? You could start by posting your specs and zipped EFI/Clover folder if using Clover or zipped Extra folder if using Enoch... May be it's a simple matter of incorrect or untuned settings.

Link to post
Share on other sites

@Bronxteck - I have tried this option but unfortunately it doesn't work

@Hervé - I am away with work until Monday but I can fire this over then. I am using clover and have next to nothing patched in the config file. Speedstepping, I get x12 x20 x21 x22 which doesn't seem complete to me, but works as I will only ever be listening to iTunes with 1/2 websites open or running it at 100% for a render. Graphics card is a Quattro but the model escapes me right now.

My new plan is a front panel fan controller, although I would love to get it all working natively for pride sake :)

Appreciate the input guys! I'll drop back online as soon as I can with the requested files.

Thanks, have a good weekend

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...