Jump to content

Success! 10.8.5 on the D430


Recommended Posts

I had a sweet d420 running ubunto with a mac theme, and i wondered what would it take to hackintosh this? Well the d420 had a 1.2 coreduo and would not run anything other than snow leopard.  So i looked online and came across these forums and herve's post and found out the d420's limits.  i looked on ebay and found a 1.33gz core2duo mobo for 10$ and some copper shims for 5$ and i did a little swap.  Anyway, I finally got Mountain Lion running in 32 bit mode.  i followed herve's guide almost to the letter.  edf v5 dont find squat anymore.  luckily herve had a nice boot pack that had everything.  one thing with the boot pack in the boot plist i had to remove arch=i386 to get it to boot the installer for 10.8.5.  easy enough.  then the hardest part, tracking down mlpf v0.03 for 10.8.4.  i managed to find a mediafire link, then i installed it to my best usb stick and mlpf wouldnt boot...so i made a partition out of left over lion space 9 gb and had to do mlpf on the internal hd & installed with the boot flags herve provided arch=i386 -f.  afterwards i had to boot into lion to run myhack and do the my fix on ml, wouldnt let me do it from ml.  I did the full fix rebooted and did the script for rebuilding 32 bit cache and it failed after 10 minutes, but its working and running.  Im typing this up on the frankintosh.  kodi plays fine, youtube works on seamonkey.  Big thanks go out to herve! I made a video

Link to comment
Share on other sites

kriss-MacBook:~ kris$ sudo kextcache -system-prelinked-kernel -a i386
IOKitWaitQuiet() timed out.
Internal error; overrun mapping executable file /System/Library/Extensions/myHack.kext/Contents/PlugIns/VoodooHDA.kext/Contents/MacOS/VoodooHDA.
Internal error; overrun mapping executable file /System/Library/Extensions/myHack.kext/Contents/PlugIns/VoodooHDA.kext/Contents/MacOS/VoodooHDA.
Can't link VoodooHDA.kext - architecture i386 not found
Prelink failed for org.voodoo.driver.VoodooHDA; omitting from prelinked kernel.
kriss-MacBook:~ kris$

thats what happens when i run script not 10 minutes more like 4 or 5 and i downloaded the newest edp and it did find the d430.  still a few graphical hiccups here and there but sweet.

Link to comment
Share on other sites

  • Administrators

Having swapped motherboards, you effectively have a D430 that happens to be in a D420 casing... Since it's a tad misleading and only likely to cause confusion, claiming or stating to run MLPF'ed ML 10.8.5 on a D420 is best avoided; as such, the title of your thread was renamed and I would invite you to do the same for your video title.
Indeed, it's because of the EDP gradual decay (lack of developers and interest oblige) that I started to post full packs that do not rely on the tool.
It would seem the VoodooHDA kext you're using that's not fat binary (i.e. 32+64bit compiled) but 64bit-only. The version included in the pack I posted is v2.8.1 and that's fat binary.
You can easily check the architecture of your kext with lipo Terminal command. For instance:

lipo -info /Extra/Extensions/VoodooHDA.kext/Contents/MacOS/VoodooHDA

If it's fat-binary, the command will return something like:

Architectures in the fat file: <file name> are: x86_64 i386

If it's 64bit-only, the command will return something like:

Non-fat file: <file name> is architecture: x86_64

As a test, I've just rebuilt my D430 ML cache and do not have those VoodooHDA-related error messages. Use the version included in the pack...


NB: I don't know if it's just the poor quality of the video but you don't appear to run ML with graphics acceleration on that D430. Make sure you (re)configure 32bit kernel mode in the Chameleon o.c.B.plist.


I'm not going to bother updating any of those old MLPF threads but the best way to run ML on those platforms with natively-unsupported GPUs is to start with a vanilla 64bit installation (w/o graphics acceleration of course), followed by all ML updates, including the security ones. Once all updates have been installed, proceed with MLPF conversion in order to run the systems in 32bit kernel mode with graphics acceleration.

  • Like 1
Link to comment
Share on other sites

well I got some good news and some bad,

1 i borked it and had to start over with the ml partition, did the updates in 64 bit mode, then rebooted into the mlpf partition"DSDT=/Extra/dsdt.aml arch=i386 -f, did mlpf for 10.8.4, booted up with arch=i386 -f .  Then i noticed itunes had the incompatible icon over it, under system info it shows as 10.8.4, well i thought that was cosmetic only and would not effect apps , i was wrong.  I found justins website for tutorial for changing the osx version, basically you type "sudo nano -w /System/Library/CoreServices/SystemVersion.plist" in terminal type your password and manually change it to 10.8.5 as if it was a text doc, ctrl-x to exit, hit y for yes, then enter to overwrite the old.   iTunes works now. 


2 the voodoo audio kext isnt causing me an issue during prelinking, see below, its doing this now:

kriss-MacBook:~ kris$ sudo kextcache -system-prelinked-kernel -a i386
kxld[com.apple.driver.AppleACPIEC]: The following symbols are unresolved for this kext:
kxld[com.apple.driver.AppleACPIEC]:     _AcpiHwRead
kxld[com.apple.driver.AppleACPIEC]:     _AcpiHwWrite
Link failed (error code 5).
Prelink failed for com.apple.driver.AppleACPIEC; aborting prelink.
Failed to generate prelinked kernel.

-I am going to try in single user mode


3 Mr herve thanks for replying to my post, i did as you said and changed the video title.  Not here to mislead. i will suggest everyone with a d420 do the mobo swap. it takes 30 minutes and the only 5 screws that are different are the 3 that belong to the keyboard & 2 for wifi the other 15-20 are a piece of cake. 10-13$for the board, 5$for copper shims, already had thermal paste,worth it!


4 Waterfox works great for browsing and youtube upto 720p, in 1080p video it becomes a still image with music just like in my yt video.  Seamonkey plays 1080p video but becomes out of sync, again its fine in 720p mode.  Kodi 16 plays like a champ for me in any resolution, if you skip around the first second or so is off then it catches up.  

Link to comment
Share on other sites

Small update i got the pre linked kernel command to work with out errors, so everything works here except sleep and wake.  Not sure whats going on there.  I couldn't get the security update 2015-006 to install either from the app store or from the combo update pkg, i used pacifist to install it, which lead to an immediate kernel panic, I used MLPF and it worked but i am back down to kernel 12.0 and the app store still says i need to install update 2015-006, so i hid the update.  I havent tried mac post factor, it does have an option for 10.8, but i am uncertain how it handles 32 bit.  Has anyone tried mac post factor on the d430?  Question for Herve, have you gotten sleep and wake working? And if so how?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...