Jump to content

Audio on E5540 in Sierra


rubbereend
 Share

Recommended Posts

Hi, 

 

Sierra runs pretty smooth on my Dell E5540, but the only problem I still have is the audio...

I can't seem to find the correct kext for this model. 

According to the dell website the audio driver is a Realtek ALC3226.

 

Does anyone have an idea?

 

Thanks!

 

Roelof 

Link to comment
Share on other sites

  • Moderators

If you're using my bootpack and following my guide, it's all included.

 

7. Copy kexts from /EFI/Clover/Kexts/Other/LE to /Library/Extensions of Macintosh SSD

    Note: Ignore warning/error messages and click OK, then run commands below.

 

8. Repair permission and rebuild cache. Run command from terminal

 

      sudo chmod -Rf 755 /L*/E*
      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo chmod -Rf 755 /S*/L*/E*
      sudo chown -Rf 0:0 /S*/L*/E*
      sudo touch -f /S*/L*/E*
      sudo kextcache -Boot -U /
Link to comment
Share on other sites

Hello, 

 

I did a complete re-install of mac OS Sierra to be sure i followed the guide correctly, when i repair permissions and rebuild cache i get the following:

 

rebuilding //System/Library/PrelinkedKernels/prelinkedkernel

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IOAHCISerialATAPI_Injector.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext

kext file:///Library/Extensions/DisableTurboBoostBattery.kext/ is in hash exception list, allowing to load

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext

KernelCache ID: 7F8AC21A2AA4FC8829621EDE0CC18F27

File at path '/System/Library/PrelinkedKernels/prelinkedkernel' changed, cannot be used

Child process /usr/sbin/kextcache[1207] exited with status 77.

Error 107 rebuilding /System/Library/PrelinkedKernels/prelinkedkernel

 

What am i doing wrong?

 

Thanks, 

 

Roelof

Link to comment
Share on other sites

  • Administrators

Nothing, you just have to repeat the touch + kextcache commands when you get that. But it seems you're missing the dummy ALC292 kext... It's available here in the bootpack and the ALC292 patch details are listed too. I'm using layout-id 1 on my E6440 (see post #7 of the thread).

 

Audio kexts cannot be injected, they have to be cached if you want Clover on-the-fly patches to work Ok.

Link to comment
Share on other sites

Hello, 

 

I've been trying again, this time with the alc 292 kext, now i don't get any errors after the sudo kextcache -boot -u / but still no audio output...

I Don't understand what you mean with ' 

 

the ALC292 patch details are listed too. I'm using layout-id 1 on my E6440 (see post #7 of the thread). Audio kexts cannot be injected, they have to be cached if you want Clover on-the-fly patches to work Ok.' 

 

BTW: i've checked dcpi manager and for audio device i get 0x80869c20, if i google that i get the alc233 instead of the alc292. Am i using the correct kext?

 

Thanks again!

 

Roelof

Link to comment
Share on other sites

  • Moderators

ALC292 is known to be causing static noise in the headphone, so VoodooHDA won't fix this issue. With the patch AppleHDA_ALC292 with combination of CodecCommander, that will be fixed.

Also will enable HDMI audio if that's important to you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...