Jump to content

Latitude E5440 High Sierra Upgrade using Clover


Recommended Posts

Bronxtech, I think what you said above is for the "from scratch" install? That makes sense then, if they changed some things for High Sierra. I have always skipped apple login during my scratch installs.


In any case I finally solved my problem. First stopped relying on Apple tools. I took my trusted free windows tool - Macrium Reflect - and proceeded to make images of each of my partitions onto individual USB sticks.

- The Mac EFI Partition

- The Mac Partition

- The Windows EFI partition (16MB partition)

- The Windows Partition.


I then whacked The Windows Partition. Now I had previously resized The Mac Partition creating 1GB of unallocated space I was hoping High Sierra would create the Recovery Partition in. It had never done so failing with that stupid error I have mentioned about Windows not being able to boot. Minus The Windows Partition on the disk, it did as I expected. Created a 650 MB partition just below The Mac Partition. So I have 350 MB of lost space now, which is fine.


I made sure I could login to Mac OS. Then restored the The Windows Partition Image back. I have dual boot working again.


So now the only mystery is Clover Menu is showing an extra item.

Boot Microsoft EFI from EFI (this boots into Windows, but why that name?)

Boot MacOs from Macintosh SSD (this boots into 10.13)

Boot MacOS from Recovery HD (this one?)

Boot Recovery from Recovery HD (or this one?)


The last 2 have me stumped. One of them is the Recovery HD, but dunno what the other one is. I'm afraid to even select and boot in case it does something I don't want and trashes my dual boot.


I'm proceeding to test out my 10.13 install now, making sure all functions and devices work.

Link to comment
Share on other sites

Okay so everything seemed to work in 10.13. 


Now I have tried to install Supplemental Update for High Sierra. Whether I try through App Store or downloading manually, it arbitrarily aborts without warning after restarting. No error, nothing.


No extra menu item created in Clover. No macosinstaller directory created either. Wierd. 


Almost like Apple is targeting machines with Dual Boot or at least Hack dual boots. At least give me an error I can try resolve :-(


It would seem just like I had to strip the HD off windows before I could upgrade from 10.12 to 10.13, I need to do that every time I have to update OS. I think I'm just going to wait for 10.14. Does not seem to be worth the trouble.


Unless of course someone who dual boots (does anyone here???) has a solution.

Link to comment
Share on other sites

This is the frustrating part. When I want to use sound it does not work. At other times it will work.

So whatever you said, I've tried all combinations. Never worked.

Decided to try one more time and turned it on. And sound just works!


So basically I don't need to try anymore since sound is working. OF course the next time I want to watch youtube it will not work, but I promise to not complain, because I need to figure out the alignment of the planets before listening to audio. :?


Right now I have a car with its fuel indicator broken. Hopefully someone will find a permanent fix one day.

Link to comment
Share on other sites

Thanks guys. Sleep + Wake seems to fix Audio.


So I was never able to install 10.13 supplemental update. It kept quitting without any errors. I expect this is because I have a dual boot on *same* HD partitioned and/or because I have an SSD and installer is confused. I was expecting 10.13.1 upgrade however to go through. Same issue.


So my question is I have downloaded 10.13.1 *full* install in Applications. Can I install this directly on top of my current 10.13 install directly? Or do I need to go traditional hack route by creating USB and following guide? Major pain if I have to do that for every OS revision. Hoping at least since I have Clover I can attempt direct install, even though "upgrade" does not work.

Link to comment
Share on other sites

  • Administrators

Dear griftopia,


From my experience updating with the supplementary update, you will see that you need to boot installer disk as it will update from an installer rather than direct update from within mac os. If I remember correctly, I just need to boot the installer twice as the first time boot will give error. The second boot should update it nicely.


Maybe this will shed some light.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...