Jump to content

[Solved] E7470 High Sierra (NVMe) fresh install failed


Recommended Posts

Hello everyone!


I'm unable to install High Sierra on my E7470. It keep KP before the installation. 


Following Jake's instructions in below link (Post #3)



And used latest bootpack (+configHS) also provided by Jake (Post #3)



I have encountered these errors in Verbose mode:

  • Kernel Panics
  • Endpoint has been activated through legacy launch please switch to XPC or bootstrap_check_in(): com.apple.xxxxxxxx
  • Warning ACPIBatteryManager changed from 7236 to 7136


Further steps I also took but had no effect:

  1. Safe mode, Single User, all available boot options.
  2. I tried both E7x70 and E7470_alternate bootpacks
  3. Removed RAM from slot B to slot A (This made progress)
  4. Removed all kexts except for FakeSMC
  5. Tried disabling Integrated NIC + Parallel Port + Serial Port in BIOS

Please help. Thanks


BIOS version: 1.17.5 (Restored BIOS defaults)

AHCI - UEFI - Legacy ROMs enabled - Secure Boot off - TPM disabled


config.plist: the one provided for HS by Jake

Clover version: v2.4k_r4268




Link to comment
Share on other sites

  • Replies 70
  • Created
  • Last Reply

Top Posters In This Topic

  • Moderators

Your M.2, is it NVMe or Sata SSD?

Doesn't matter since HS supports NVMe natively.

Reason the drive is not listed is because it only lists bootable drives and your M.2 is not. Not until you have formatted and installed MacOS or Windows.


Disable Legacy Option ROMS in the BIOS.

Replace the attached file and folders into /EFI/Clover and try again

Boot with verbose and debug 0x100 mode


Link to comment
Share on other sites

Now it doesn't show any bootable drives...


As for the M.2 drive, it is showing M.2 PCIe SSD-0 in BIOS.. So my guess it's NVMe.


Edit: Just to make sure I install Clover correctly, I select the following options:

  • Install for UEFI booting only
  • Install Clover in the ESP
  • Drivers64UEFI > OsxAptioFixDrv-64


Edit 2: Also in Clover boot menu, it has the following options pre-selected:

  • Disable KASLR (slide=0)
  • Set Nvidia to VESA (nv_disable=1)
  • In Boot Args: slide=0 dart=0 nv_disable=1 kext-dev-mode=1

CPU-Z screenshots attached for reference.


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...