Jump to content
mariolasagna

Dell Latitude 7480 - High Sierra: Any how-to?

Recommended Posts

Many fanx ! Try tomorrow in work, in home i dont have dock. 

But now, TV in kitchen work with my notebook! 

You are the genius, man!

Respect from Russia fun :)

 

Tested D1000 today

Yes!!!! Working now! All monitor are visible!

But have one nuance - if i close lid - notebook are going to sleep in 30 sec and dock switched off.

May be this glitch of D1000 and 10.13.4  Legal is here in top : http://www.displaylink.com/downloads/macos (white on black)

and D1000 work only with one USB.

Share this post


Link to post
Share on other sites

Hello Guys!
 
Just recently (month ago) bought a Latitude 7480, I'm happy to find people who was able to hackintosh the laptop, but I tried to install High Sierra with no success.

First of all, the installer or installed macOS wont detect trackpad nor keyboard, so I had to connect a usb mouse and keyboard. Voodoo kext for keyboard and trackpad did not work.

After that, the Intel HD 620 reported to have only 7MB of VRAM, and the CPU was undetected. I tried spoof the CPU (as I seen on different forums, that the 7200U is not compatible with hackintosh), but no success.


Had no wifi, no sound, no anything, and the system in general was slow as crap.

After trying to start all over again, after a normal reboot, all I have is kernel panics right at boot, right from the HD, and also booting from an USB made with unifail, that used to work.

Do you have any guide, or any starting advice to install High Sierra on this laptop? I'm not a noob with hackintosh, I'm a mac user since 7 years, and have installed hackintosh in lot of PC and Laptops.

Very best regards.

Share this post


Link to post
Share on other sites

High Sierra Clover vanilla guide, use attach as bootpack.

Here is all the updates that's done to 7480 so far, all put together. Place contents into /EFI/Clover, overwrite them

Kexts inside /EFI/Clover/kexts/Other/CopyTo/L/E is self explanatory, but if not, they are to be copy to /Library/Extensions of the install drive as post install. Not the Installer!

Repair permissions and rebuild cache. Reboot

Make sure to be on latest Clover v4439 (at time of writing this).

Intel Wireless is not supported. Bootpack include patches and kexts for DW1560 or DW1830 (supported cards).

 

7480_HS_10.13.4.zip

Share this post


Link to post
Share on other sites

Well, I wasn't lucky. 

What I did was:

 

1) Created USB install from "Install macOS High Sierra.app"
2) Installed Clover with the config in the guide on the USB drive

3) Downloaded the generic EFI zip, extracted, and replaced the files to the EFI folder on the USB drive

4) Same thing with the bootpack attatched by Jake Lo

 

When I try to boot, the installer stucks, but without a linear pattern.

If I enable verbose mode for Clover, I can see that the installer stucks in the middle of a string shown on the screen, but completely random.

For example:

"Apr 20 08:24:15 Users-MacBook-Pro GoogleSoftwareUpdateAgent[345]: 2018-04-13 08:24:15.484 GoogleSoftwareUpdateAgent[345/0x700002d6c000] [lvl=2] -[KSUpdateEngine updateAllExceptProduct:] KSUpdateEng                                            " 

"Apr 13 08:24:16 Users-MacBook-Pro StatusBa                               "

Every boot, it get stuck in a different line, but almost after the same time (just a few seconds).


I'm completely lost right now...

 

Share this post


Link to post
Share on other sites

Hello guys!


First of all, thank you Jake Lo for helping me the other day with trying to boot the High Sierra USB Installer for my Latitude 7480.

I wasn't able to boot with High Sierra installer, but was able to boot Sierra Installer, and install it without many issues. Actually, I'm on 10.12.6.
I'm trying to get most things working, and then try to update to High Sierra.

The issues I'm having Right now are:

- No trackpad working, tried VoodooI2C kext, but did not work

- No HDMI video or audio. Video solved changing SMBIOS. Still no audio.

- Audio jack not working. With AppleALC I can only hear noise from headphones from the jack, and with VoodooHDA the headphones output just don't work when selected, but mic and speakers work.

- Problems with sleep. Not sure if the system don't wake and have a black screen, or it is just that the screen gets black while waking from sleep (very low priority, really don't bother me to not be able to sleep).


Can you help me with at least the trackpad issue?

Best regards.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...