Jump to content

E7440 from Mavericks to High Sierra


cazy
 Share

Recommended Posts

First of all thanks to Jake Lo, Hervé, Vietnam and others for their help when I installed Mavericks with Clover early 2014. It has been working great all these years but now i have the time and I need an update!. I have an Msata coming to clone my drive and experiment, the question is do I need to update in progression or bypass all versions and go directly to Sierra or High Sierra?

One thing is I need to preserve Win7, Win8.1 and HFS+ format.  Here are my specs:

E7440 10.9.5

Processor  2.69 GHz Intel Core i7

Memory  8 GB 1600 MHz DDR3

Clover 3.20

BIOS ?? need update

Thanks all

Link to comment
Share on other sites

  • Replies 21
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Moderators

Before doing anything, have a bootable USB installer ready incase of issue.

You need to upgrade to latest Clover first, reboot and see if it still boots. Then upgrade to the latest E7440 bootpack capable of High Sierra, reboot and see if it'll boot. Copy your serial # and such if you have it working for iMessage...etc

Then you could upgrade directly to High Sierra.

Side note, if you want to keep HFS+ format, you'll need to run the installation from the terminal with commands to skip APFS conversion.

See here under upgrade section

 

Link to comment
Share on other sites

  • Administrators

With regards to cancelling the default APFS conversion of the target High Sierra partition, one can also reboot the HiSie USB installer after the installation process has created the temporary "macOS install from ..." partition and initiates a 1st reboot. Then, the idea is to modify the minstallconfig.xml file located on the macOS Install Data folder of the target partition/volume and change:

<key>ConvertToAPFS</key>
    <true/>

to:

<key>ConvertToAPFS</key>
    <false/>

with a basic text editor like vi.

 

Once the mod is done, the "macOS install from ..." partition can be booted to complete the High Sierra installation in HFS+ mode (or whatever scheme the partition was originally made with).

 

https://hackintosher.com/guides/how-to-opt-out-of-apfs-in-high-sierra/

 

Link to comment
Share on other sites

As always thank you guys, OK I got an Msata drive (Samsung 860) I plugged into the WWAN port, cloned and everything went well, 16Gb/minute, not too bad. Booted with 860 updated Clover went to App store download High Sierra and Install file is only 23mb, I said WTF ???. I researched and this problem is very common even in real Macs, there is a workaround on the net to DL from Apple server but I didn't want to do it I don't know the origin of the patch.

Well anyway I found Sierra in the App Store I DL and created 2 USB installer one using createinstallmedia and the other restoring OS X Base System both panicked at boot.

I found then Yosemite in the purchased section of the APPStore I downloaded and created exactly the same way as the others using same bootpack but in a third USB drive and this time booted and Installed.

Internal audio is not working and the trackpad drives me crazy but I'm not bothered because my goal is HS. My next step is to make a new Sierra installer but with this third USB flash drive.

I tried installing from the Desktop and also panicked, also not matter what I tried I cannot see fixheaders in Clover configurator I can only applied in options at boot but doesn't help.

Any ideas?

 

Link to comment
Share on other sites

8 hours ago, Jake Lo said:

Did that solved your issue?

No, but I found out what is Panicking I blocked inject kext VoodoPS2controller.kext and booted up, of course no mouse or keyboard.

I tried lots of versions of this kext and no luck,. any idea?

if I pass this hurdle I need to ask you about WIFI, I thought I was safe but looks is not the case.

If helps I'm in BIOS A22  Sierra version I DL is 12.6

Link to comment
Share on other sites

 Share


×
×
  • Create New...