Jump to content
karde

(SOLVED :)) High Sierra - Dell latitude 7480 - :/ please help (keyboard/trackpad/bluetooth and wifi)!!

Recommended Posts

Hi,

 

I have "successfully" installed High Sierra on my latitude 7480, but, can't get the built in keyboard and trackpad to work :/, can only controll with external keyboard and mouse.

I've tried the ApplePS2SmartTouch kext and VoodooPs2Controller kext under kext other on the EFI partion and under /Library/Extension, won't work, anyone got any tips :(, would really appreciate any help!! 

 

Thanks a lot!

Share this post


Link to post
Share on other sites

Okej, so I manage to get the keyboard to work, installed voodokextpscontroller.kext under /Libarary/extensions and under my EFI but no luck with the trackpad.

 

If I have this and either ApplePS2.kext or Appleps2smarttouchpad.kext neither the keyboard or the trackpad works..

Also, with only appleps2controller.kext / appleps2smarttouchpad.kext neither keyboard or mouse work :(, anyone got any tips for the trackpad? :(

 

THANKS!

 

 

Share this post


Link to post
Share on other sites

Wow, your files are a mess!

Duplicate kexts in /S/L/E and /L/E and in /EFI/Clover/kexts/Other

You'll need to clean it up a bit by first removing all the added kexts in /S/L/E and /L/E

If you don't know which kexts, look in your kextcache_log.txt that you attached.

If VoodooPS2Controller only works in /L/E, then just leave that one there.

 

In /EFI/Clover/kexts/Other, remove the following:

  • AppleHDA_ALC292.kext
  • IntelBacklight.kext
  • EAPDFix.kext
  • FakePCIID_Intel_HDMI_Audio.kext
  • NullCPUPowerManagement.kext
  • FakePCIID_HD4600_HD4400.kext
  • IntelGraphicsFixup.kext
  • Shiki.kext

Update LIlu.kext (v1.2.5) and add latest WhateverGreen.kext (bundled with Shiki.kext and IntelGraphicsFixup.kext)

Repair permission and rebuild cache.

Reboot to Clover, press F4. 

Continue to OSX and attach new debug file. Your last debug is missing the Clover folder so I don't know what you have in your Config file

  • Thanks 1

Share this post


Link to post
Share on other sites

I ended up reinstall the system :/, sorry for the mess :)!

 

I have attached the new debug file and my EFI folder.

 

Do I need to compile Voodo-PS2-Controller for the trackpad to work :(? Is the below the right procedure? Got error in Xcode during this, so wonder If I'm doing right..:

 

Install Xcode
git clone https://github.com/usr-sse2/OS-X-Voodoo-PS2-Controller.git
cd OS-X-Voodoo-PS2-Controller
git checkout 3fdrag
open VoodooPS2Controller.xcodeproj
In Xcode window, select scheme 'All Kexts'
Press Command-B
Right-click Products/VoodooPS2Controller.kext in Xcode window and select Show in Finder

 

I have VoodoPS2 only on EFI now and keyboard works, no trackpad 😕.

 

Thanks for all your help and patience with me!!! I really appreciate it, would be great to the the trackpad to work!

debug_10153.zip

EFI.zip

Share this post


Link to post
Share on other sites

 

Hi @Jake Lo

 

IT WORKS :)!!!! Did not on first boot, was worried, but now it does.

 

Have you got any tips on wireless and bluetooth, bluetooth settings appears in system settings, but can't find any devices to connect/they wont show up as discovered, if you have any tips on that as well I would be glad :)

 

Thanks again for your time!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...