Jump to content
karde

(SOLVED :)) High Sierra - Dell latitude 7480 - :/ please help (keyboard/trackpad/bluetooth and wifi)!!

Recommended Posts

Would be really glad with help regarding this :(, attaching Config.plist and debug.

I can start the machine with either charger plugged in or charger plugged out, but plugin in or out after start freezes the machine..

(last error I have so would be happy to get it working, I'll have to buy a bluetooth/wifi card/dongle, but to get the charging issue sorted out would be great ūüėē)

Thanks a bunch!!!!

 

debug_18146.zip

EFI KARDE.zip

Share this post


Link to post
Share on other sites

That works! But :/, now the built in keyboard / trackpad won't workūüėā, I can see the below message during boot (voodoi2c¬†going to sleep), with Legay option on keyboard/trackpad works but not swapping to charger, please help;/:

 

IMG_0162.JPG.1ca3391792d04cacbf94a3fb081b2528.JPG

debug_23731.zip

 

thanks!

Share this post


Link to post
Share on other sites

hmm sounds like your bios might not have ps2 EFI module when running in UEFI mode have you checked dell for bios update maybe they mention a correction for PS2 or you can try add the clover installer driver modules for PS2 its worth a try.

  • Thanks 1

Share this post


Link to post
Share on other sites

Tried different version of BIOS :(, same issue...

Tried to download voodops2 from https://bitbucket.org/RehabMan/os-x-voodoo-ps2-controller/downloads/

no keyboard :(, tried Alps ps2-controller, won't work..

 

@Jake Lo was kind enough to provied me with working ps2controller, before them the trackpad wouldn't work.
If anyone knows what the problem might be I would be really happy, shall try to reinstall, but would rather if it was possible, make it work without.

Share this post


Link to post
Share on other sites

Did a clean install, plug/unplug charger works if Legacy Option ROMs is uncheck but no trackpad or keyboard, please help :(!!

 

Share this post


Link to post
Share on other sites

YES :)! It works!! THANKS!!!!! :)

Thanks!

 

Sorry, now I've been asking to much, but, I wan't to use a bluetooth dongle, have an IOGEAR, I wan't to avoid replacing my built in card..

The problem is though that osx shows my bluetooth settings, but, I can't turn bluetooth of, inserting the bluetooth dongle won't work, seems like osx wan't to use the built in one.

Tried with bluetooth explorer and change it under Tools/HCI Controller Selector, won't work..

Tried with:

sudo nvram bluetoothHostControllerSwitchBehavior=always

 

Won't work.. :(

Is there any settings in clover you could use or any terminal commands, can't find any..

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...