Jump to content
griftopia

Mojave on M6400 and M6500 - Any hope?

Recommended Posts

So I have a M6400 and a M6500 running High Sierra 10.13.6. I can imagine M6400 it might be nigh impossible to get Mojave installed - it is Core2 Duo. On the other hand my M6500 has a i7 CPU and was wondering if it was possible to "fool" MacOS into installing by using SMBIOS for a more recent Apple with i7.

 

On both the M6400 and the M6500 I cannot download Mojave to AppStore. It gives a message it's not possible to install on the machine. I tried to force the issue by copying the Install from another laptop, but when I did on the M6400 and selected Macintosh HD, it said not possible. Imagine it will do same on the M6500, except I'm hoping there's a way to hack my way through it.

 

Has anyone tried installing Mojave on M6500?

Share this post


Link to post
Share on other sites

Core2Duo CPU is not an issue in itself as long as it's a Penryn model. The issues at hand are:

  1. SMBIOS profiles such as MBP7,1 (anything older than a 2012 model is natively unsupported)
  2. Vanilla telemetry plugin triggers KP on C2D platforms
  3. GPU support (no native support for non-Metal GPUs)

 

Dosdude1's patcher normally takes car of this:

  1. it patched the PlatformSupport plist to inject some of those natively unsupported models (eg: MBP7,1, MBP8,x, etc.)
  2. it replace the telemetry plugin by a previous version from High Sierra

 

As for GPU support, older nVidia GPUs can  be supported by installing nVidia kexts from a previous macOS version such as High Sierra 10.13.6

 

See details re: D630 in my Mojave beta thread here.

 

Share this post


Link to post
Share on other sites

Finally was able to recover my password. Hopefully my issue solved for good. Was reason not able to get back earlier.

 

So I kept trying to patch Mojave install but was not succeeding. Finally did what I think I shouldn't have had to do. Downloaded the Mojave install from the dos dude app itself. Then patched, or maybe the problem was 10.14 vs the recent 10.14.1 update.

 

Anyways, to cut a long story short, I downloaded Mojave Install from the dos dude app, then patched it with MacBookPro 6,2. This is for my M6500. Then created USB stick. Then downloaded and installed latest version of Clover. Then copied dsdt, config and kexts on the USB stick. Obvious things...

 

So had problem with unresponsive keyboard for selecting drive to install from (maybe Clover issue) but kept trying. Finally was able to finally get keyboard to work, and did an inplace upgrade. Remembered to patch HD install with dos dude. Now M6500 now running 10.14.1 with same issues as before I was never able to fix - no sleep, and left hand side USB ports not working. The former is problem, the later I can live with.

 

Then I proceeded to install the latest clover onto the HD as well. As it turns out dsdt/config/kexts did not get trashed. And also did not get trashed from LE. So there are really no files to post. Anyone wanting M6500 files can take from posts when I did Sierra/High Sierra. All in all, in retrospect, this was really quite painless - I just wasted time patching Mojave Install downloaded from AppStore, will not make that mistake again.

 

I will now try with M6400 which will need patching with MacBookPro 7,1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...