Jump to content
Semaj

[SUCCESS] E6330 running Mojave 10.14.2, includes EFI and 10 step mini guide

Recommended Posts

ACPI config is wrong! You're placed a DSDT from the E6230 as "DSDT_A19.aml" in ACPI/patched folder, yet your Clover config calls for "DSDT.aml". Instead you've referred to "DSDT_A19.aml" as one of the SSDT by sorted order. I don't think that's gonna work.

 

-> Either rename "DSDT_A19.aml" to "DSDT.aml" or refer to "DSDT_A19.aml" in your Clover config and remove "DSDT_A19.aml" from the listed of sorted order SSDTs.

Share this post


Link to post
Share on other sites

I wonder that how I could miss this naming...

 

After I renamed the dsdt_a19 to dsdt, everything started working! Now every USB ports, even the sound card started working!

 

THANKS EVERYONE AGAIN!!!

Share this post


Link to post
Share on other sites

just enable uefi, with secure boot off, then apply and exit. after the laptop restarts itself, push F12 button, to enter custom boot selection menu. and the you have to choose uefi:your_usb_identifier option to boot from

Share this post


Link to post
Share on other sites
On 2/11/2019 at 7:05 AM, Hervé said:

The E6230 does not require renaming of USB2 controllers from EHCx to EH0x. They will work perfectly with the vanilla names. What's important is to cache or inject a USB injector kext + inject Darwin in DSDT in order to gain USB3 capabilities. USB2/USB3 multiplexing can then be obtained with Rehabman's FakePCIID+ FakePCIID_XHCIMux kexts.

 

I would expect the E6330 to work and behave according to those same paradigms.

 

Attempting to pull this thread back on to the topic of the E6X30 + Mojave 10.14.2...

 

Herve - do you think the requirement for USB2 controller renaming depends on BIOS?  I am still using A11, have not yet upgraded to A19+

On the other hand, if A11 is working for me on the E6230, is there any reason to upgrade to A19 for Mojave?

 

Thanks-

Share this post


Link to post
Share on other sites

I have updated my install to 10.14.2. Well to be fair, I forgot to disable auto updates and macOS did it. No issues to report. I'm confident creating an installer using the 10.14.2 app will ok. I'm happy this thread has helped some people get macOS up and running. Mine is still running smoothly. Using it daily.

 

One of my few wishes is to hack some support for the stupid Intel Turbo memory card that was in there. Would be nice to use that 1GB for swap.

Share this post


Link to post
Share on other sites

I can’t get .4 to install. Either update or clean.

 

I have updated all kexts on the installer like AppleALC, WhateverGreen and Lilu. No updates for the others exist. 

 

The installer boots but never makes it to the gui. After a long wait it says kextd stall for AppleACPICPU. 

 

Update: installing the latest Clover fixed it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...