Jump to content

Dell Vostro 270s (Ivy Bridge) Mojave Project Stuck


MrJonesIII
 Share

Recommended Posts

Hi all, 

 

I have a Dell Vostro 270s desktop. Hardware configuration can be found here - 

 

http://linux-hardware.org/?probe=9ed34a7310 

 

In summary it's 

  • Intel Core i5-3470S CPU @ 2.90GHz
  • Intel HD Graphics 2500
  • Dell Inc. Motherboard 0478VN A00
  • Dell Inc. BIOS A12 03/20/2018
  • 7 Series/C210 Series Intel Chipset 
  • Onboard Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
  • Onboard Qualcomm Atheros AR9485 Wireless Network Adapter
  • Intel B75 Express Chipset LPC Controller
  • I’m using a WD 1TB SATA HDD
  • There is a USB 3.0 controller in there with a USB 2.0 one as well that I’m using for the USB Stick. 

 

I'm using a 8GB USB stick that I've successfully used many times to install on various Hackintoshes I've built so I know it's ok. I've also tried every USB port on the computer. 

 

I've tried using the install guide and bootpack from here - 

https://osxlatitude.com/forums/topic/11148-wip-dell-vostro-200-st-with-c2d-e8600-geforce-gt730-gt1030-high-sierra-mojave/?tab=comments#comment-86695

This got me also to the flashing underscore. (This required legacy boot.)

 

I tried following these instructions here

https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/config.plist-per-hardware/ivy-bridge 

copying the raw code for the config.plist, and it got the Apple logo, but nothing else. Tried verbose but it didn't give me any clue as to why it stopped. Something about the hardware sensor and then it just stopped progressing. 

 

I'm really sorry, but I don't know where to go from here with this one. Any help would be greatly appreciated. 

 

The unit has no PCI cards, just trying to use the internal Intel graphics on the motherboard. (Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller) 

 

I've attached my EFI partition contents zipped. My Config.plist file has a unique SN that I've checked. 

 

For this configurations which gives me the flashing underscore, I used the guide for the Vostro 200 desktop above, copying (replacing) the KEXT/Other folder and the ACPI folders as per the instructions. ( I'm not sure if I was meant to merge or replace so I replaced thinking that the poster would have simply copied them rather than going to the trouble of pulling out individual files for a merge to work.) 

 

Thanks in advance and looking forward to any and all advice and comments. 

 

Regards, 

 

MJJ

 

 

EFI Partition Contents.zip

Link to comment
Share on other sites

Thanks for the replies. 

 

I've got Mojave working with help from an old nVidia Quadro K600 card I found and took the full height bracket off. Seems quite zippy truth be told. 

 

Most things seem to be working, including both the DisplayPort and the DVI connector (2560 x 1440 on the main DisplayPort display too!) however, I can't seem to get the audio to work, nor the internal Wifi or Bluetooth, although I'm not sure it has Bluetooth to be honest. USB 3 works, I'm pretty sure I’m getting GPU acceleration. Ethernet is working. 

 

EFI Folder attached. 

 

I tried to fumble around with the ALC fix thing but I've got no idea what I'm doing with that and can't make heads or tails of any of the "guides" I've found online. They could just as well be writing in Chinese, I've got no idea what they're talking about or how it's supposed to be used to make it work.

 

Again, the Linux HW probe reports that the Dell Vostro 207s' motherboard's onboard audio is called - Intel Corporation7 Series/C216 Chipset Family High Definition Audio Controller. Here's a link to the Linux details of the driver they use for Mint Debian Linux - http://linux-hardware.org/index.php?id=pci:8086-1e20-1028-0576 

 

If anyone can help me with some layman instructions for getting it to work I would be very grateful indeed! 

 

Thanks, 

 

MJJ 

EFI.zip

Link to comment
Share on other sites

Hi Jake, 

 

Thanks for that and for being so patient with me. I'll skip the wifi altogether. It's not that important on a desktop. The audio is, however, very important, so I've followed the instructions to gather useful information and posted it on that link you sent. I'll write back with my progress so that it's also mirrored on this post in case someone else is going through the same as I am with a Dell Vostro 270s. 

 

Regards, 

 

MJJ

Link to comment
Share on other sites

Just tried to apply the 10.14.4 upgrade and now the system is broken. Tried to boot verbose with nVidia forced, but it switches from the verbose to the Apple logo and progress bar stuck at about 60% and the drive is making a lot of noise. After about 30mins, the screen goes blank and although both monitors are active (not being put to sleep), and the HDD is making noise, there's no desktop. Pressing keys makes a bonk bonk bonk like noise. I've tried safe mode (refuses to boot), I've removed every peripheral other than the mouse and keyboard. I'm not sure where to go from here. Any suggestions? 

Link to comment
Share on other sites

Strange things I've noticed now, trying different things - 

  • Attempting to boot in safe mode gives me a circle with a line through it. 
  • When the progress bar appears it's always around the 60% point. It moves maybe three small moves and then stops. The drive stops accessing for a bit and then something times out and the screen goes blank. The second screen, however, turns on (blank) and the drive starts making accessing noises again. There's no mouse, nothing, but the screens are awake. 
Link to comment
Share on other sites

 Share

×
×
  • Create New...