Jump to content

E6530 Mojave Post Installation


nathanh0
 Share

Recommended Posts

@Jake Lo @Hervé

 

Hey guys. I have been diligently searching the forums to get my E6530 booted up with Mojave 10.14.4.

 

I am currently logged in to Mojave, with...

 - Sound (VoodooHDA / Layout-ID 12),

 - HDMI (1080p), 

 - HD4000 Integrated Graphics,

 - 16GB Ram,

 - 2 TB HDD (not SSD).

 - Messages works (natively with my iPhone X).

 - No freezes at all, everything is smooth.

 - Graphics are great, plays 1080p nicely!

 - Sound is great too.

 

What I need help with:

 

 - [big problem, I need more USB ports] Only 1 USB port works (back left diagonal).

     - I need help with Left USB (no power, no recognition)

     - I need help with Right USB (has power for iPad, but not detected)

 - [not important] Internal WiFi card not recognized (to be expected, probably an Intel card, not supported?)

    - I replaced with an external WiFi card I had laying around.

 

I figure you guys have dealt with this already.

Attaching my current EFI folder.

 

I just want to thank you guys for working so hard for us

E6530-EFI-Mojave-10_14.4.zip

E6350-EFI-10_14.4.zip

Link to comment
Share on other sites

  • Administrators

Your kexts set is incorrect: you're injecting AppleALC (for audio) and that's all you need. Get rid of those VoodooHDA + patched AppleHDA kexts you're trying to inject too.

 

Re: USB, I did not see any ACPI folder in that Clover folder of yours so it's difficult to know if you are injecting a patched DSDT + a CPUPM SSDT for your CPU. If your USB ports are not all working, proceed as follows:

  • Download latest Clover Configurator app
  • Edit your config.plist with CC
  • Properly inject MBP9,2 SMBIOs (right now it's an empty shell)
  • In ACPI section, addd renaming of EHC01/EHC02 to EH01/EH02
Link to comment
Share on other sites

 

@Leook

 

When it booted up, my screen filled with long vertical lines and got really bright, I'm not sure what happened but I never made it to the login screen. Possibly something with the graphics.

 

@Hervé

 

Is there somewhere I can go to collect all of the SMBIOS? Also, would that affect USB?

I set the renaming as you requested, this did not have any effect.

 

More things I tried:

1. It was suggested to install UsbInjectAll.kext to the OS and make the 2 rename suggestions you told me to do.

2. I also tried the Mojave USB patches 1, 2 and 3 for 10.14.4 (this didn't work either).

 

I wish there was someone on here with my exact Latitude E6530 that has 10.14.4 working. I could only get my setup working from someone's E6230 EFI.

 

Right now, sound, 1 usb and HDMI/graphics work, so I can't complain too much.

 

If you have anymore ideas let me know.

 

 

 

Link to comment
Share on other sites

Greetings!

Got a same laptop as OP, managed to get most of the hardware working by installing his EFI dump and fixed the USB by applying patch by @Jake Lo.
The problem is that if the USB patch is applied, the brightness control via Fn+Up/Down stops working, but it works well on the OP's EFI dump.
You can control the LCD brightness well almost until the moment while Mojave finishes booting, but a few seconds until logon shows it stops working and the brightness automatically changes to nearly 50%. 

What may be causing it?

@nathanh0, is the brightness control working for you?
Thanks a lot to everyone for your work here.

 

 

udp: noticed that if you put laptop to sleep after booting Mojave, the brightness seems to be around the maximum after wakeup.

Mojave_EFI_10.14_E6530_usb_wo_bright.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...