Jump to content

Precision 7510: Mojave build


Recommended Posts

Hey Folk - here goes first post :)


I have lurked for a number of years and built a number of hackintoshes in the past but recently started looking at getting Mojave installed on my Dell Precision 7510. The specs are as follows:


Intel(R) Xeon(R) E3-1505M v5(Quad Core 2.80GHz, 3.70GHz Turbo, 8MB 45W, w/Intel HD Graphics P530)

Nvidia Quadro M1000M w/2GB GDDR5 

Samsung 950 ProNVMe Drive

Samsung 850 Pro 2 TB SSD


At the moment I have Ubuntu and data stored on these 2 drives so the M2 interface has been disabled in the BIOS and the 2 TB SSD has been replaced with a new Samsung 860 1TB QVO SSD


I am planning on purchasing a Broadcom Wifi card (any advise on what to get appreciated).


I have been trying to build this all pretty slowly and understand all steps involved but been struggling to actually do this and have reverted to using an EFI\CLOVER folder that I found on a TM thread (#54). I tried for quite a few hours last night to build up my own EFI\CLOVER from scratch however could never quite get things booting.


Not ideally what I wanted to do but I am sure this EFI\CLOVER might be a good starting point.


I have disabled the dGPU using modified version of Dell_E6540_UEFI_eGPU_configurator_by_nando4 so I am now trying to get the IGPU P530 working.


At the moment "No Kext Loaded" is shown however I have tried setting the AAPL,ig-platform-id to a supportable 191b from the actual 191d


This seems to show in IOReg but something is not working or I'm missing something.


I've attached EFI and IOReg - any help appreciated


  • Like 1
Link to comment
Share on other sites

Thanks. Isn't the HD530 the same hardware as the P530? I thought it was but might be wrong.


Anyway I have tried a number of different Ids:

  • 191B0000
  • 19120000
  • 191B0006


I have set as shown:



Any suggestions on what Id I might want to try ? 


Link to comment
Share on other sites

  • Moderators

That's progress!

That just means your DVMT is not set.

Boot to Clover Options, go down to Graphics injection and change Igplatform-id and fakeID to 0x12345678

Continue booting to OSX. 

Repair permissions and rebuild cache

Now reboot normally.

Basically the Skylake FB needs to be caches in order for the patches to be apply on-the-run ...so to speak.

To prevent this in the future, you could set DVMT with EFI shell, see guide here.

Link to comment
Share on other sites

@Jake Lo - I just tried this but on the reboot following the permissions repair and cache rebuild the machine didn't; start up.


On the Clover Options screen think I took the rights steps:


Drilled down to Graphics > Selected the InjectId check box and changed the Igplatform-id and fakeID to 0x12345678


When the machine was back up I ran:

sudo chmod -Rf 755 /S*/L*/E*
sudo chmod -Rf 755 /L*/E*
sudo chown -Rf 0:0 /S*/L*/E*
sudo chown -Rf 0:0 /L*/E* 
sudo kextcache -i /

Is there a decent utility for ˆ ?


Then I rebooted and the screen was as shown below:





Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...