Jump to content
dm4n

Clover pack for Mojave on Precision T3500...

Recommended Posts

Hi @Next One,

 

Would you be willing to share your Config and EFI folder for the T3500?

 

I'm getting a startup issue where the BIOS seems to be resetting the RAID settings and I'm having to F2 into BIOS every boot and change RAID and SpeedStep. This is on the latest Clover.

 

Thanks

 

Share this post


Link to post
Share on other sites

Define "latest Clover".

 

Did you enable/activate the AppleRTC fix in Clover? Please note that if you run Mojave 10.14.4 or later, you also need to update Clover to, at least, r4911 as explained here. You may also see Dids' GitHub repo.

Share this post


Link to post
Share on other sites

Hi dm4n,

sure I can do that, but first I have to get Audio sorted as I am trying to move away from voodoohda and use Lilu/AppleAlc and Mojave.

The T3500 has AD1984A codec but I have the issue that with AppleALC the devices are seen but still no sound is played from them. (Headphones and Lineout, clover Inject 11/13/44)

(I`d like to figure this out because then sleep appears to work well, which is buggy with voodoo)

The codec has been added to ALC recently but there seems to be some problem with injection in the latest versions, and I have found no solution to it yet.

I have no HDEF in my DSDT, so if somebody has a tip on how to add this in I`d like to try. 

 

Maybe Hervé has a hint, as AD1984A seems to be common in similar machines like the Optiplex series:

780/760 has AD1984A

755 has AD1984

T3500 has AD1984A

 

would this make sense ?

           Device (HDEF)
            {
                Name (_ADR, 0x001B0000)
                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x08)
                    {
                        "built-in", 
                        Buffer (One)
                        {
                            0x00
                        }, 
                        "layout-id", 
                        Buffer (0x04)
                        {
                            0x1C, 0x00, 0x00, 0x00
                        }, 
                        "PinConfigurations", 
                        Buffer (Zero) {}, 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }

 

For the BIOS reset Problem I think it could be:

  • CMOS Battery
  • Clover not at 4911 (I use this)
  • Mojave not at .6 version
  • SMBIOS not updated for MP5,1 for the newer BIOS definition (use Cloverconfigurator) 
  • Like 1

Share this post


Link to post
Share on other sites

If HDEF (or whatever other audio device  name) is not defined by default in your DSDT, maybe it is in an SSDT. You can dump all raw BIOS tables by pressing F4 at Clover main menu and then check things out. All extracted tables will be saved in EFI/CLOVER/ACPI/origin folder. But you probably already know that...

 

  • Like 1

Share this post


Link to post
Share on other sites

You can also inject it in Config file using Clover Configurator.

You'll need to enable FixHPET, FixMutex and FixDarwin if you don't have these in your DSDT.

Inject with layout ID = 13 or 11 if that doesn't work

  • Like 1

Share this post


Link to post
Share on other sites

So here goes the T3500 Pack:

 

I took a different approach to minimize effort and only use ssdt, no more DSDT, try attached EFI Folders.

( I added HDEF to DSDT but it did not help and voodoo seems to work better without, as HDA does not load)

Only using //Patched: SSDT_LPC.aml to get "pci8086,3a18" loaded for PM/AppleLPC.kext.

 

EFI Folder Voodoo: Sound works, sleep/wake works.

EFI Folder ALC : Sound shows icons and values in sysprefs (and AppleHDA is loaded, see pic), but does not actually play sound.

(I tried to resolve sound but apparently it is not that simple - at least I couldn't. Lots of info on ALC / AD1984A / Mojave being a problem.) Sleep/wake works too.

 

Hardware is T3500 w W3680 cpu, GB Aorus AMD RX570, ASMedia Sata3 Card w/ 2 SSDs, a TP-Link wifi card , and 24 Gig Ram.

 

I will continue to play with the settings in the plist checkboxes to minimize as much as possible.

If you find there are useless settings (or important ones missing) in the config.plist please share your knowledge here.

 

Give it a try...(EFI is from clover r4911/Mojave 10.14.6)

Good luck

T3500 pack.zip

  • Like 1

Share this post


Link to post
Share on other sites

@Hervé I'm using Clover v5070.

 

@Next One That's awesome, thanks. Will have a play with those config setting and the ssdt.

 

CMOS battery has been recently replaced. OS is Mojave 10.14.6 and SMBIOS is Mac 5,1. AppleRTC box is checked in Clover Configurator> Kernel and Kext Patches.

 

Update: Still getting the RAID reset problem on startup.

 

 

Share this post


Link to post
Share on other sites

I don't think RTC fix is needed.

Have you checked that your MPro5,1 smbios is up to date (Boot-ROM-Version: 144.0.0.0.0 I think it is in "about this Mac")

In clover configurator you can see a Date for the Bios , it should say something like 2019, not 2010.

If not choose a random different smbios; and then MPro5,1 again and this will be "renewed". (Note your serial if you like to keep it)

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...