Jump to content

DELL PRECISION 7510 (SKYLAKE) - SHORT BATTERY LIFE


nickelnoff
 Share

Recommended Posts

I have pretty short battery life on my laptop (specs in sig). 

 

Basically I am not sure why but in around 2 hours of web browsing the battery is just about gone.

 

I seem to have speed stepping working and the frequency can be seen to vary with the Intel Power Gadget.

 

 1752475091_Screenshot2019-10-12at00_25_31.thumb.png.5a20c82b1f8c8dfe31d323174e891e26.png

 

However AppleIntelCPUPowerManagement.kext does not seem to be loaded.

 

Any help appreciated.

Link to comment
Share on other sites

  • Administrators

Little chance of seeing AICPUPM loaded on a Skylake system... CPU power management is handled by the kernel since Haswell! AICPUPM last applies to Ivy Bridge.

 

Unsupported but not disabled dGPUs drain battery on Hackintosh laptops, hence why we always try to disable them through specific SSDTs.

Link to comment
Share on other sites

Thanks @Hervé was aware of these Skylake particulars.

 

On 10/12/2019 at 1:06 AM, Hervé said:

Unsupported but not disabled dGPUs drain battery on Hackintosh laptops, hence why we always try to disable them through specific SSDTs.

The method I used to disable dGPU was via UEFI configuration method does this not have the same end affect as SSDT disabling?

Link to comment
Share on other sites

  • Administrators

I've no idea about the particulars of that said UEFI configuration. But if you do not see the dGPU in IOReg, I guess it would do the job...

 

NB: No signature, so no specs in signature as stated in post #1.

Link to comment
Share on other sites

  • Administrators

No, there's nothing else known to drain a battery, except the heavy graphics-oriented nature of the OS.

 

Maybe you ought to reconsider your UEFI method and switch to SSDT to disable (=power off) your dGPU. That's a guaranteed method.

  • Like 1
Link to comment
Share on other sites

it's an OS thing in my opinion. Same on my Skylake Acer, on Windows draining with ~1-2W (when doing regular things for example browsing), on macOS it's ~5-6W, with dGPU disabled, power management\HWP enabled, I even lowered my idle CPU frequency to see if anything will change but no, I can't do anything about it. 

on Windows I could use my notebook for ~4 hours, but on mac it's barely 2 hours. That's not problem for me because I often use my laptop for 3D graphics\editing and I need to be on AC every time for that.

I wonder what's up with Linux too, maybe the same.

 

Maybe we could have better battery time with an aftermarket battery that has plus mAh.

Link to comment
Share on other sites

@kushwavez agree to a point. Never used windows much on this system. I seem to recall when the system was first bought through I was getting a little bit not load more battery life. But then NVidia dGPU was not disabled. 
i was however getting 3+ hours battery life with Ubuntu 18.04 though. Again with NV disabled. As you say could just be the OS but I suspect there is some thing draining since I’ll get jump decreases when doing things like rebooting. 
another thing I have seen is that the fans can be noisy and then I’ll sleep the system and wake and the fans have quieted  down and battery drain seems to have slowed. 
 

@Hervé I removed the UEFI disabled method last night and ran a CMOS reset to get back to default settings. 
Clover now shows (under Graphics option) both GPUs a present however unable to boot successfully back in to Mojave. 
 

Kernel panic seems to occur followed by a reboot. 
 

I tried removing boot option: -wegnoegpu 

 

tried adding -nv_disable=1 

 

tried adding checking InjectNvidia using FakeId: 0x12345678 

 

any suggestions on how to proceed?

Link to comment
Share on other sites

10 minutes ago, Jake Lo said:

You need to enable Switchable graphics in the BIOS.

Thanks @Jake Lo- managed to get booted up. 

 

I seemed to have needed to clear other config renames out as well as SSDTs - not entirely sure what was responsible but now writing on very choppy graphics with the NV dGPU running. 

 

Will try and disable. Any help appreciated.

 

Currently seeing:

 

88466701_Screenshot2019-10-14at15_41_11.thumb.png.23fd9adf0c1ca4ec9dfd1f54a97ab276.png

DSDT.dsl.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...