Jump to content

[SOLVED] E6230 Fresh installed Catalina: boot with dimmed brightness -> screen off -> go to sleep -> power off


Recommended Posts



Clean installs Catalina. At a boot time brightness of a screen are changes from normal to a minimum. Then the screen is completely off and laptop is going to sleep state (power button is slowly blinking) if press power button laptop is powered off.

If a laptop connected to the docking station boot process is going as normal and no problem occurred.

Debug log attached.



Link to comment
Share on other sites

  • Administrators

Booting straight into Sleep usually is a sign of incorrect settings for CPU power management but you seem to have all in order. I see a CPU-specific SSDT for an i5-3320M matching your signature so I presume you generated it yourself since it appears it was compiled under 10.15.1. Everything indicates you used my E6230 Clover boot pack so I think it's fair to say you also followed my guide.


Did you install any kexts in /S/L/E or /L/E for caching too are are you just injected kexts from Clover?


The only obvious thing that differs between our individual setups (outside the Bluetooth kexts which, imo, are irrelevant to your predicament) is the BIOS version; I run A19 when you're still on A11. I would most certainly recommend you update to A19 too. A new version A20 got out since since I myself updated but I've not proceeded to install it; maybe it's time I do...

Link to comment
Share on other sites

Yes, Hervé I'll followed you guide and generate own SSDT file.

I have added kext for Bluetooth module DELL DW380 to the /EFI/CLOVER/kexts/Other/ BRCM_RAM3.zip

And 10.13.6_IO80211Family.kext.zip to the /L/E for Atheros AR5B93 WiFi module. But I try and remove all kexts

rebuild cache but result is the same.

I'll upgrade bios to A19 and write a result soon.


Link to comment
Share on other sites

  • Administrators

Just updated BIOS to A20 and all is working perfectly with Cover patches and patched A19 DSDT.


This being said try and adjust your Clover config with Clover configurator app to compare:

ACPI config

  1. remove PluginType
  2. Add Drop SSDT CpuPm
  3. Add Drop SSDT Cpu0Ist
  • Like 1
Link to comment
Share on other sites

Hervé, thanks a lot!

I updated BIOS to A20 and make changes in ACPI config in Clover and it's work like a charm.

But one little thing a little annoying me- all time blinking wifi indicator. I'm figured out what is Bluetooth related "bug".

I patched Info.plist file in FakeSMC with code for Mojave:


        <key>DW380 Bluetooth module: PID 0x413c/16700, VID 0x8197/33175</key>

and added BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM3.kext. All works good except all time blinking WiFi indicator.

Maybe you know what it is?

Link to comment
Share on other sites


  • Create New...