Jump to content

[Solved] Dell Precision 5510 error could not allocate runtime area


Recommended Posts

I have been trying to install catalina on my dell precision 5510 the whole day but i'm always stuck during boot with error "could not allocate runtime area"
I followed vailla guides as well as guides specific to precision m5510 and xps 9550.

I tried all varients of aptiofix. tried to find my own slide value by getting hex values of my memmap though i might not have been able to get correct value.
I also tried open core alternative to aptiofix with no luck either.
i read other topics and can confirm i have two ram slots occupied.
bios settings are also set accordingly
Any help would be appreciated

 

Current System

Dell Precision 5510

Core i7 6820

2x8gb ddr4

512GB nvme SSD Liteon

 

Link to comment
Share on other sites

  • Moderators

Follow my vanilla Clover guide for Catalina here, including BIOS settings

Use bootpack from here, goes into /EFI/Clover after you installed Clover 

Update Lilu.kext + Whatevergreen.kext, VirtualSMC.kext, SMCBatteryManager.kext, AirportBrcmFixup.kext, USBInjectAll.kext

Remove AppleBacklightFixup.kext

 

  • Like 1
Link to comment
Share on other sites

 

23 minutes ago, Jake Lo said:

Your LiteOn NMVe drive might be causing issue. Try this Config, added a patch for the bit swap block size

config.plist.zip 4.95 kB · 1 download

No luck. stuck on same place

 

44 minutes ago, Bronxteck said:

right now it looks like it is stalling out on audio. disable whatever you are using to load the audio and see if you get further.

Confused. do u mean i disable audio from bios?

Link to comment
Share on other sites

ok. with this i was able to land on installation screen
now there are two  issues

  1. catalina cant be installed without internet connection. is it normal?
  2. when erasing the drive where i need to install, it fails saying 
    Quote

    MediaKit reports not enough space on device for requested operation.

    i have single 512 gb nvme drive which i want to dual boot with windows 10. i dont want to format the drive. is there any other solution?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...