Jump to content

E5440: random wakes and KPs


marlov
 Share

Recommended Posts

@Jake Lo I think I've used those commands already, but I did it again and will come back with more details soon.

 

I tested my headphones just to check if I had no problems like our friend @CheBoludos, it worked fine in one youtube video. Then I opened another tab and I got not more sound hahaha I'll try to catch up with what you've done che, any doubts I will come back here 😛

 

Also, I'm buying a dw1510 wifi card, because dw1550 was so expensive for me :c Do you guys think it will be alright for me? 

Link to comment
Share on other sites

  • Moderators

DW1510 works just fine, just no Bluetooth. You'll need to restore 2 kexts from Mojave if you're running Catalina as it's no longer supported.

Your audio setup is correct, just move CodecCommander from Clover kexts to /L/E if you haven't already. Then repair permissions and rebuild cache.

 

Link to comment
Share on other sites

well, I did something that's making my e5440 kinda crazy

when booting, often it says that there's no bootable device. Or, boot to clover and there are no disks, OR, go to clover, boot to disk but got a prohibit sign, OR, boots normally. Usually takes 5 tries to get it working, some of them making it boot from "Mac OS X" via one-time boot menu, but it doesn't fix all the time.

 

What I did was:

    In /Library, there were the Extensions folder and a folder called Extensios or something like that, when I opened it, it had a Content folder, just like a .kext file. Well, I assumed I made something wrong in the past and mistyped that, so I deleted the folder.

    Copied the CodecCommander.kext and DisableTurboBoostBattery_2.3.kext from my efi/clover.../copytole, just to make sure I didn't made a mistake with them, considering that extensios folder..

 

    Googled how to repair the kext permissions from the cmdline, found out:

 

sudo chmod -Rf 755 /S*/L*/E*

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /S*/L*/E*

sudo chown -Rf 0:0 /L*/E*

sudo kextcache -i /

  

    Did those commands, but after that, I found one of from Herve here in the forum that was

 

sudo chmod -Rf 755 /S*/L*/E*

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /S*/L*/E*

sudo chown -Rf 0:0 /L*/E*

sudo touch -f /S*/L*/E* sudo touch -f /L*/E* sudo kextcache -Boot -U /

 

 Well, I did them as well, just to make sure

 

 

Now my computer is crazy 😛 

 

Any ideas why and/or what can I do to fix it?

Also, I did those hibernation commands that @Jake Lo recommended above

Link to comment
Share on other sites

  • Administrators

No bootable device, hmm... Make sure your boot disk is physically properly set in its place and has not moved. This error message is typical of situations where SATA connector is not fully fitted in the slot.

 

As for the random wake, did you check your Energy Saver settings? You may have Power Nap or Wake on network access options activated...

Link to comment
Share on other sites

@Hervé I checked for wake options in BIOS, they are all disabled. 

I'll clean my ssd conectors to check if helps

 

 

3 min ago I just got another panic, which froze my entire system. That's the second since I've installed macOS. 

I don't have a lot of ideas why, but here's the "report for apple" 

https://pastebin.com/HXRWEXNH 

 

 

edit: Nop, cleaning the conectors didn't resolve the issue.

I'll try to reinstall clover whenever I have time, I think it's a problem with it somehow. These kind of things usually happened to me while testing other/wrong efi folders. The only weird thing is that they took that long to start happening, and matched me messing around with kext..

 

Link to comment
Share on other sites

  • Administrators

make sure you have HFSplus and apfs driver loader on your boot device as well as on the usb. clover sometimes gets overridden and might boot from usb but when it finds an EFI on the HDD it will pull the files and folders from there first. if the files are not there or corrupted then it will behave as you described.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...