Jump to content
PayPal donations: [email protected] ×

Recommended Posts

:)) Told you it's probably easier this way. Well, at least in my opinion, it is.

 

Stuck at that point, usually (at least in my experience) signifies an issue with FakeSMC/VirtualSMC. For as far as I can see, you chose to use VirtualSMC.kext. No problem with that (unless for some reason your laptop prefers FakeSMC.kext instead), but I think, for this case, you might also need the VirtualSMC.efi drier in drivers/UEFI. Seems to be missing in your case.

 

Now, of course, I could be wrong and this might be an entirely different issue. Just sharing my own experience in case it helps.

Share this post


Link to post
Share on other sites

yep i included virtualSMC efi , still stucking at the end, maybe somthing is wrong with the config plist ? 

Also are other macOS version as hard as this catalina ? i mean i tried mojave with the same config Jakelo gave me it showed "report panic to apple" and didnt boot.

Share this post


Link to post
Share on other sites

Guys, please refrain from using quotes to post replies. Forum provides a Reply box at bottom of pages.

Share this post


Link to post
Share on other sites

Sorry, Hervé. Didn't even realise I was using quote. Ok, will try to pay more attention to that. Thanks for pointing it out and editing to remove those quotes. :)

@theawesomerb, in my experience, no, it's not. I mean, usually, at least for desktops, there are very few changes to make to the config (if any), from one version of MacOS to the other. And from Mojave to Catalina for example I don't think I had to change anything in the config. So no, it's not really common, at least on desktops. Could be be pretty common for laptops though.

Share this post


Link to post
Share on other sites

Guys i'm happy to tell you i made it :D at lease the install , i need one final help to finish this

 

for start redownload olarilla new version from their website , i replaced ONLY the config plist provided by jakelo (BIG THANKS) ; after that, i started the install , on first boot i used the other config plist from olarila (because jakelo's causes it to crash on the final step), and voila , done deal , installed correctly and booted up

 

the problem now , is the mouse , i can"t use the mouse pad , and the usb doesn't work, wifi doesn't work neither, please help on this final step :) , for 3350 owner i share with you the EFI that worked for me

ethernet doesn't work neither , and when i sleeps i cant' get back , i'll have to shut it down mannually and reboot using usb stick

3350CustomBoot.zipmac2.thumb.jpg.4136867b2e9c883114667f9599905646.jpg

Share this post


Link to post
Share on other sites

Which Config file are you using to boot now?

I see Config3 is from my files.

What wifi device does it have? We are not mind reader...we need detailed information.

Intel wifi are not supported yet, so you'll need to replace it with a compatible device...ie DW1560, DW1830 or DW1820a. Avoid Atheros model.

For mouse, replace the voodooPs2Controller with the version from my files and see if it make a difference. If it still doesn't work, you'll need the Alps version.

You should be able to safely remove these kexts as well:

You should understand what each kext is use for, remove unnecessary kexts

  • AtherosE2200Ethernet //Atheros ethernet
  • LucyRTL8125Ethernet //Realtek Ethernet
  • SmallTreeIntel82576 //Intel Ethernet
  • IntelMausiEthernet //Intel Ethernet
  • NoTouchID // for model with TouchID to disable it
  • NullCPUPowerManagement //disables powermanagement, mainly used for desktop system
  • RealtekRTL8100 //realtek Ethernet
  • XHCI-unsupported //Sata controller

Add from my files the following kexts:

AppleALC //needed for audio

SMCBatteryManager //needed for battery status

SystemProfilerMemoryFixup //add the Memory tab for About this Mac (Optional)

Share this post


Link to post
Share on other sites

Thanks Jakelo , i cannot thank you enough my friend, you re such a high quality member !

 

these are my first linnes from my use utilisation of hackintosh, thanks to you and arsradu.

 

while waiting for your answer , i went ahead and removed the config , ktext and ACPI from the EFI and i put yourse, boom everything works except wifi , bluetooth and mousepad.

 

i fixed the wifi problem by using my dongle DWA 131 , installed the driver from this generic software that supports alot of dongls 

https://github.com/chris1111/Wireless-USB-Adapter/releases/tag/V11

 

for the bluetooth i dont care for now

 

about the mouse , should i use this : https://osxlatitude.com/forums/topic/8285-refined-alps-touchpad-driver/

(latest R6?) didnt want to try it out of the blue and maybe brake the system without your advice

this is the last thing i need to fix then i ll make a tutorial for 3350 owners. 

 

Again i can't show you enough My gratitude Jake lo.

 

 

Share this post


Link to post
Share on other sites

well after I run the command here is what shows up

 

Installing debug report generator....
Checking your internet connection....
Internet connectivity is all good to go.
Downloading the latest version from GitHub...
cp: /usr/bin/gen_debug: Read-only file system
chmod: /usr/bin/gen_debug: No such file or directory
Tool installed successfully.
Would you like to generate a report now?[y/n]: y

/Users/  /Downloads/install_tools.sh: line 54: gen_debug: command not found

 

I looked around , is there something up with 'SIP' ?

also the pc is being incredibly slow, 4go of ram isn't enough ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...