Jump to content
PayPal donations: [email protected] ×
dave.stl

E7470 Big Sur Beta Installation

Recommended Posts

Hey everyone,

 

i wanted to open this topic because I haven't seen any similar here.

 

I tried to install Big Sur Beta 2 on my Latitude E7470 and ran into some Problem.

Has anyone successfully installed Big Sur on the E470 or an similar Latitude?

 

I dont know if its better to make an fresh install or an upgrade from my Catalina installation. Bu didnt want to mess up my Catalina installation so im more into an clean install.

So for that I read, that Copencore (0.6.0) is the better option. But i ran into some problems again. Some where caused by some outdated kexsts. After upgrading or disable them the boot stuck a bit later in kind of an loop.

 

After this weekend i will provide additional information, but if anyone mad any progress pleas let me know or give me an hint ;)

 

Thanks in advance,

David

 

Share this post


Link to post
Share on other sites

-> Moved to macOS beta versions section...

 

Wisdom and common sense dictate to tell you that you'd be ill advised to try and upgrade a working Catalina installation to Big Sur beta. 10.16/11.0 remains in very early stages and quite troublesome on Hackintoshes. We've deliberately avoided to open up too much discussion on Big Sur given the difficulties of installing it on non-Apple hardware. It's too early days and it requires a thorough driving license. You may opt to join the conversation that started at InsanelyMac if you wish but it got kinda crazy.

Share this post


Link to post
Share on other sites

@dave.stl

 

Give this a try. Successfully tested to boot from USB installer Big Sur Beta 2.

Config include settings for DW1820a, if you don't have that device, make sure to comment it out.

It'll be wise not to upgrade or install over your Catalina as Hervé advised.

Either get an external drive or replace with a spare M.2 drive if you want to test Big Sur

 

E7470_OC.zip

 

Update to latest OC release and kexts

E7470_OC_0.6.2.zip

Share this post


Link to post
Share on other sites

Thanks for providing this, but i got no luck with booting up the installer. I think i got an kernel/cpu panic right after lilu is loaded. I took your EFI and just changed the Device Properties to my serial and so on. Or do i need an special SMBIOS configuration.

 

(Even my Catalina is not starting up with your EFI) 

Share this post


Link to post
Share on other sites

I just uploaded a new bootpack. Had to make a minor adjustment since it won't detect me NVMe drive in OC Picker. Tested to boot to Catalina & BS successfully.

Share this post


Link to post
Share on other sites

Still not working on the Installer. But in the completed install it works. Trackpad and Sleep is not working for me, but every thing else is fine.

 

Thank you for providing your bootpack.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...