Jump to content
PayPal donations: [email protected] ×
dave.stl

E7470 Big Sur Beta Installation

Recommended Posts

Hi, I'm not able to use iMessage when using this EFI, I changed serial number, SMUUID and motherboard number. When i log in it just takes me back to to sign in window. Im using DW1560. Does anyone have any ideas what I can do? Thanks in advance.

Share this post


Link to post
Share on other sites

Gentlemen,

 

I am having a really hard time to get the installer with BS Beta 10 to boot up, but keep hitting a kernel panic. It's either this one, or in some cases where only the last line of the kernel panic appears (Contact apple etc etc). Weirdly, it happens randomly and not because of changes. The struggle is that, in the past, the kernel panics at least gave me a glimpse of what was wrong, and with this one, i can't get much information out of it.

 

I've tried the OC Vanilla Guide very carefully as i wanted to get familiar with OC. The issue happens in both 0.6.2 and 0.6.3. Needless to say, debug releases dont seem to help much either as the log file gets scrambled with <0x00> after 2-3 seconds in to the boot (a rough estimate). Even generating the SSDT's with SSDT Time or using the prebuilt ones gave the same result. I also tried using the latest unreleased kexts just to see if kext support may be the issue.

 

I've tried all the EFI's here as well, even the latest one from Jake Lo, with the same result. I even tried to incorporate Jake Lo's config carefully to 0.6.3, again with the same issues.

 

config.plist / EFI Files (image)

 

A few things i did before the overall OC setup, was to Unlock CFG, Unlock Overclocking (for undervolting future use) and changed the DVMT flags.

 

My current specs on the machine are:

i5-6200U / UHD 520

16GB RAM @ 2400mhz (Crucial)

SSD1: Micron 2200S (not supported by OC/macOS, but this will be dedicated to Windows).

SSD2: WD SN520 (2242 format on the WWAN slot, dedicated for macOS, yet to arrive).

Also, current screen is 1366×768 but got a compatible 1080p incoming.

Using stock 8260 Intel Wifi since it's supported (but not injected in OC yet).

Latest BIOS (October), correctly configured.

 

I dont think the hardware is majorly different, i even tried using the exact UHD 520 layout on the config.plist but that doesnt seem to be the culprit.

Share this post


Link to post
Share on other sites

Confirmed. That evil monster.

 

Anyway, i assume i can make use of the Device Properties to disable it similar to the unsupported dGPUs, right?

From the Device Manager location path in windows, i found out that it sits on PCI bus 0, target id 0, and something else 0.

Would this suffice? Or is the SSDT the right way?

 

Screen Shot 2020-10-22 at 14.56.11.png

 

EDIT: Yea, that didn't work out. I can't find much documentation for Device Properties, and those that i found seem to be used mostly for GPU's.

Share this post


Link to post
Share on other sites

Yes, this one's a very weird one. Micron 2200S, i cant believe i didn't check that link to see the KP on it, but my mind was telling me that only happens when one tried to install on it.

 

OpenCore clearly has parted way with it:

 

Quote

Dortania Vanilla Guide - Storage options to avoid.

 

SSD/Storage Options that are NOT supported:

  • Any eMMC based storage (commonly found in netbooks, some tablets and low end computer models.)
  • Samsung PM981 and PM991(commonly found in OEM systems like laptops)
    • Even if PM981 has been fixed with NVMeFix (opens new window)version 1.0.2 there is still plenty of kernel panics issues
  • Micron 2200S
    • Many users have report boot issues with this drive

 

I'm expecting my WD SN520 to arrive any moment specifically researched and ordered for macOS. Had a friend tested it for me on his e7470. It's a 2242 NVMe SSD that works on the WWAN slot as long as you change fastboot to thorough (which we obviously need to) and enable it as PCIe on the Disk list in the BIOS. The slot runs at x2 speed, but that's not a buzz killer.

 

I will have to dig in to knowing how to disable it, either through Device Properties or SSDT. I like the challenge, seems like something worth learning :).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...