Jump to content
PayPal donations: [email protected] ×
WhenMusicAttacks

E7240 - Battery drain - IGPU power management

Recommended Posts

Hello! I am running e7240 with Mojave using files from bootpack (and maybe some tuining here and there) . I have huge battery drain compared to windows though. I did a couple of things to get around this, gotten better runtime but still maybe half than what i get in windows:
- disabled card reader in bios
- undervolted cpu gpu cache with voltageshift
- disabled turbo boost
i noticed with intel power gadget that the igpu is always at 0.55ghz and only going up, but never going down even when idle. Isn't it supposed to be at 0 when under no load?
I see a couple of ACPI errors when loading the system. I tried to debug with "sudo kextload AppleIntelInfo.kext" but got " /Users/vanilla/AppleIntelInfo.kext failed to load - (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8)."

CLOVER.zip

Share this post


Link to post
Share on other sites

No, iGPU does not run at 0MHz when idle; lookup your CPU specs on Ark Intel web site or CPU World. iGPU frequency range is usually detailed. It's a dGPU that you disable if fitted and unsupported.

 

I'd say your battery drain issue has more chance to result from your incorrect CPU power management settings:

01.jpg

 

02.jpg

 

You have a Haswell platform so all you need is:

ACPI tab:

  • Plugin Type set to 1
  • PluginType enabled

Kernel & Kext Patches:

  • KernelPm
  • (you can keep AppleRTC patch of course!)

 

Nothing else. So remove those incorrect SSDT drops (especially as you're not using any CPU-specific generated SSDT) and those C-States you've enabled. Also, what is that SSDT-PNOT table you use? Not necessary to me...

Share this post


Link to post
Share on other sites

Thank you very much for your answer.


C States are supposed to be idle states and should improve battery life, that was my guess, and they sure did no hurt when i did these (igpu issue was already there). I removed them anyway and also the acpi drops, CPU still idles at 800mhz.

 

But the issue with igpu remains, every system i ever did with intel GPU idles at 0mhz, even with older Ivy Bridge hd4000, so something is definitely wrong on that side.


I used the 7x40 bootpack on this forum to setup the machine, it all works good (except for hdmi at more than 1080p but that's not an issue here). I could try to raise the stolen memory to 128mb to see if that changes anything.

things i tried :

  • remove the connector patches under devices (not the stolen memory patches)
  • disable the dock patch in kexts to patch
  • disable all the C states checkboxes (actually made no difference in idle pkg consumption)
  • gonna remove PNOT (i got that in the bootpack..)

Share this post


Link to post
Share on other sites

Excellent this screw thingie if it weren't laughable! Though not sure this is what the OP was writing about (no mention of poor system performance).

 

As for iGPU idling at 0MHz, I confirm that it's not possible. If using Intel Power Gadget, maybe OP confused OS required graphics frequency and actual iGPU frequency... Here's the registered behaviour of the HD4000 iGPU of the i7-3540M of my idle Latitude E6230 under Catalina 10.15.6:

PowerGadget_IvyBridge_HD4000.png

 

OS_requested_freq.png

 

iGPU_freq.png

 

 

OP did not indicate anything on his E7240 specs or post an IOReg extract, so maybe it's just a matter of having an AMD dGPU fitted but not disabled... Who knows?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...