Jump to content

D630 need help.


Recommended Posts

I made this thread because the other one is a mess.


so far I've tried almost everything to try and get it to work.


the D430USB thumb seems to be the best, however I can't locate the extra folder to swap it with the D630, as a result it hangs when i'm trying to go in setup.


I tried the myhack method on the wiki, it also hangs during setup... the ISO i have of SL is about 8.1GB, i'm not sure if that's the problem because I googled and a torrent shows that the SL image is only 6GB+


Sooooo I'm trying to see what I can do... why doesn't the D430USB file have the extra folder?

Link to comment
Share on other sites

after further testing, I think something's wrong with the boot file off OSX site.


I was able to use a plain D430USB pen drive and boot off a D620

but after I used my hack to replace the extra folder with the D620intel folder of the site, it hang at the start of the set up exactly like how my D630 is hanged up.


very weird in deed.

Link to comment
Share on other sites

sure thing, I'll do it sometimes this week, I'm stuffed with finals this week, so I might not have time to test these machines out. I have 10.6 running on my D620 so it's no biggie, I might just go Lion on this D630 and see if it helps the situation.


and this is the instruction for making the D430USB drive using window.


1) Extract the file SLD430USB.img.bz2, use 7zip, that's the easiest program to use in window, the result is the SLD430USB.img file.

2) Download dd for windows http://www.chrysocome.net/dd

3) Place the SLD430USB.img and dd in the root of your C drive (don't have to, but this makes it easier)

4) Open command prompt (start > cmd) right click on cmd and run it as admin

5) run the command "Diskpart"

6) run "list disk" and locate your pen drive

7) select the pen drive by typing in "select disk #"

8) type the following commands (enter them every line)


create partition primary



9) exit out to the command prompt again and type dd bs=1M if=sld430usb.img of=\\?\Device\Harddisk1\Partition0 –-progress


Before you do step 9, make sure harddisk1 is your USB drive, you can do this by doing the command dd --list or in "Diskpart" check using the command list disk.


that's it, then wait for the pen drive to be done...


since it's labeled as D430 I'll assume that it has to work with the D430 computers, I use it with my D620 and it worked, so I can also assume that it'll work with most D620 (I have the intel graphic on my D620).


that's it, this is just a add on to the guide written in wiki, that one was way too short, i ran into a lot of problems before figuring it out.

Link to comment
Share on other sites

Dear clockwork,


Try to boot with mach_kernel arch=i386 -f -v and let me know where it get stuck. We need more information before we can assist you.





hi, i booted with that, it almost got into setup, but for some reason, when it comes to the setup screen, it just grey out with the mouse at the top left of the screen and I can't move the mouse at all unless I add in a USB mouse.

Link to comment
Share on other sites

  • Administrators

Hi everyone. I too am encountering failure, despite several attempts.


My D630 setup is:

  • Intel C2D T7500 2.2GHz FSB800
  • 2Go DDR2-667 RAM
  • 160Go SATA HDD 5400rpm
  • Intel Graphics (965GM) -> X3100?
  • WXGA+ LCD 1440x900
  • Audio Sigmatel 9205
  • Broadcom 10/100/1000BT
  • Broadcom Wireless
  • Dell Bluetooth adapter
  • Unmodded A17 BIOS (i.e. I tried the modded version, but results are worse with it)

Installation attempted with Retail Snow Leopard 10.6.3 DVD.


Initial attempts were with a HDD already set with Win7. From Windows, I reduced the Win7 partition to recover disk space and created a new main partition formatted NTFS.


I made a USB boot key with Nawcom ModUSB + SL 10.6.3. Installation goes through Ok (I believe using legacy_kernel) and everything works at straight reboot of HDD (full video resolution, sound, keyboard, trackpad, wifi + 10/100/1000BT + Bluetooth + dual boot) except two main defects:

1) SL has to be booted with external screen plugged in and video output directed to it (FN F8) otherwise screen goes blank after Apple grey screen with spinning wheel. With external screen plugged in, screen reverts back to built-in LCD to provide initial Welcome Video/Normal boot completion (this is not reached with modded BIOS).

2) can only update to SL 10.6.7 (without single issue), but SL 10.6.8 causes unrecoverable boot failure.


This is the closest I can get to successful installation! If EDP 1.9.2 kexts are then installed, I will just get blank screen on built-in LCD at end of boot, no matter what.



I then decided to copy the bootpack to the USB boot key, thereby replacing ModUSB's Extra folder. The result was a system only partially installed:

1) built-in keyboard was not recognised, I had to use external USB keyboard.

2) after installation of EDP 1.9.2 and appropriate kexts + Chameleon installation, I only obtain blank screen at reboot! If I boot with external screen plugged in, built-in LCD remains black but external screen is usable (albeit empty because acting as 2nd screen).

3) only if I reboot off USB key and then select newly installed SL partition do I obtain full reboot on built-in LCD, but I cannot get full screen resolution and other stuff.

4) no installation possible on MBR partitions, I had to delete everything and opt for GUID partitions.


I then decided to follow the Wiki's recommendation and, using previous partial installation, went the MyHack way. I deleted my USB boot key and restarted everything with MyHack 3.1 + Retail SL 10.6.3 DVD. It took a while, but new USB boot key was created and I replaced the /Extra folder by that of the Bootpack.


Installation is then a complete failure. On pressing F12 to select USB key to boot from, I do get the Chameleon screen showing "My hack OS Install disk" from which system appears to boot. After some lenghty period of time, screen for to grey Apple logo with spinning wheel, but after some additional period of time, screen just goes blank!


I've tried to use various options/flags to fix the issue (-x/-v/-f/PCIRoot=1/GraphicsEnabler=No), but no success.


Could anyone provide a detailed step-by-step installation method for that lappy? How did those who succeeded manage to get SL 10.6.8 installed?


Thanks in advance for your advises.

Link to comment
Share on other sites

ok it's installing now on my D630...


the problem was a real stupid one.


the boot pack I downloaded from here wasn't the right one. not once but twice, not my fault, i think in the process of revamping the site, someone uploaded the wrong one (not once but twice lol)... I just re-downloaded and it worked.


I still have the older one on my flash drive as that was the one I've been using...


so far the keyboard don't work, but i'm sure once I get in there, I'll try to make it work.

Link to comment
Share on other sites

  • Create New...