Jump to content

OS X on AMD system


Alex
 Share

Recommended Posts

Hello,

First,thank you guys for putting together this great site.Thanks to your guides I already have Dell D420 running OS X.

Now I decided to install OS X on my "ancient" AMD system using the "AMD system tutorial" from the site's front page.

 

My specs:

Motherboard: Asus A8N-SLI Deluxe (It's socket 939 board!)

http://www.asus.com/Motherboards/AMD_Socket_939/A8NSLI_Deluxe/

AMD Athlon 64 X2 3600+

1.5GB DDR

Powercolor Radeon HD4830 Display Connectors: DL-DVI/HDMI/VGA

(Note: compare to HD 4850, the difference is that AMD reduced the number of shaders from 800 to 640.I would assume driver wise should make no difference.)

640GB Sata HD with Windows 7

80GB IDE HD for OS X installation.

IDE MagDog DVD burner/reader

WiFi card: D-Link DWL-520

Sound card: Asus Xonar Essence STX.

 

Monitor: SAMSUNG 2343BWX native resolution 2048 x 1152.

 

I followed the guide and amazingly 30min later I have Snow Leopard 10.6 running on my system!

Note: I didnt burn SL retail to DVD.I used 8GB USB stick instead.(restored image using OS X disk utility)

 

What is not working:

Video HD4830 runs at 1024 x 768,no acceleration.I tried "GraphicsEnabler=yes"

parameter - no change.

Swaped HD4830 with old Geforce 6600GT,the same result - no acceleraton.

No sound yet - I still have Asus Xonar installed - need to remove it.

 

Now,I can mess with HD4830 and try to get it to work.

Or maybe just buy a cheap video card that is fully supported

by OS X.

I will update on my progress.

 

Thanks again,

Alex

Link to comment
Share on other sites

Update:

Great Success is not so great (: yet..

 

I upgraded from initial SL 10.6 to 10.6.8 using SL combo update.

Installed the Legacy Kernel 10.8.0 v2

Installed radeon hd4830 kextx for SL 10.6.8- now I have full acceleration and native resolution on both DVI and VGA connected monitors!

 

What doesnt work:

Issue #1: "Spinning wheel hickups" - the system would became irresponsive for 4-5 sec while accessing or just hovering "Apple" logo on top left corner and also application menu in "Safari" for example and another apps.VERY ANNOYING!

System monitor shows no spikes of activity and the hard drive is not reading writing.

 

Can it be AMD specific issue? I installed VoodooTSCSyncAMD.kext tried to boot "arch=i386 -force64".No change.

 

 

Another issues:

-seems like I lost my USB ports(cant recognize USB drive).Strangely wired Apple

keyboard is working.

-after shot down or reboot my BIOS resets itself to default settings.

-WiFI D-Link dwl-520G has stopped working(was working fine in SL 10.6 before the update)

-still no sound.

 

Fixing Wifi and sound is on the botton of my list.

 

Does anyone have any idea what can cause the OS lag?

 

I would appreciate you help.

Alex.

Link to comment
Share on other sites

ElliottForceLegacyRTC.kext. fixed BIOS reset problem - thank a lot!

 

I reinstalled SL 10.6.0 retail back again to track down and isolate the cause of the OS lag I get

when update from SL 10.6.0 to SL 10.6.8

 

Everything is fast and snappy(except graphics acceleration) in SL 10.6.

 

WIFI (D-Link DWL -520G) and USB ports are working fine in SL 10.6.0 - what kexts do I need to backup before updating?Will they be compatible?

 

I tried both AC97 and VoodooHD kexts for sound - none works.But fixing sound is on the bottom of my list.

 

Thanks,

Alex

Link to comment
Share on other sites

UPDATE:

 

Finally after reinstalling SL 15 times,rebooting 100 times and generating 200+ lines of log file in the proccess I have SL 10.6.8 with full video accelaration,wifi and sound working!

 

The biggest challenge was to find working SL "update version + legacy kernel + working video kext" combo.

Some SL "updates + kernel" combos would give KP for example:

"SL 10.6.7 + legacy 10.6.7 = panic

SL 10.6.5 + legacy_kernel_10.6.5_V2.zip = panic"

 

SL 10.6.4 + legacy kernel would boot fine, but I couldn't get video acceleration to work.

 

Anyway with little (if you lucky) or a lot of patience it is possible

to run SL even on such an old hardware as mine.

 

Thank you for sparkling my initial interest by posting the guide.

Alex

Link to comment
Share on other sites

Good stuff! Do give us the way you manage to get everything working, it can always be useful to others.

 

Well, I used the AMD installation guide from this site to install SL 10.6.0.

I still had no video acceleration,no sound and every computer restart would reset my BIOS settings to default.

So I had to "google" to find solution/kexts to fix these issues.

Link to comment
Share on other sites

I Have the same motherboard 'a8n-sli' i know how to get the sound working but updating iaktos 10.6.3 is a nightmare,

can you tell me how its done must have done about 5 reinstalls now :-(

 

here is the driver you need voodoo is no good remove all old kexts and install this

 

Hardware Overview:

 

 

Processor Name: Intel Core 2 Duo

Processor Speed: 2.21 GHz

Number Of Processors: 1

Total Number Of Cores: 2

Memory: 2.5 GB

Boot ROM Version: MP31.006C.B05

 

also my graphics card is an xfx 7300 gs, i dont think i have full graphics support neither :-(

 

any help would be great

 

cheers

Link to comment
Share on other sites

 Share

×
×
  • Create New...