Jump to content

[Solved] E6440: Big Sur and OpenCore


Recommended Posts



I've create a USB installer as per Dortania's OpenCore Install Guide, but I'm unable to boot into the installer. The last line of the OpenCore log reads

30:552 00:027 AAPL: #[EB|LOG:EXITBS:START] 2020-11-24T08:38:41


According to the troubleshooting section, this issue might be caused by CFG Lock, which I did set to 0. I've tried the EFI folder from the post E6440 Big Sur just out of curiosity, and the loading process went passed the stage I'm stuck at. However, the EFI folder from the linked post contains a patched DSDT.aml and doesn't align with the OpenCore guide. Hence, I would prefer to have a clean EFI folder.


I have attached my EFI folder which I'm having issues with to boot the installer. Product information properties in config.plist were removed for obvious reasons.


Thank you in advance.


Link to comment
Share on other sites

Update: I was able to boot the installer after    replacing all SSDTs in the ACPI folder with the once I currently use with clover, and adding the corresponding patches to the config file. 
In the next step, I removed the EHCI-01/-02  SSDTs/patches as well as the EC patch and added the SSDT-EHCx_off.aml. This aligns more with the OpenCore guide and the booting process went past my initial issue. However, I think I’ll need the EHCx SSDTs and patches to get the build in camera and Bluetooth working. I’ll complete the installation over the weekend and post my EFI that aligns as close as possible to the OpenCore guide.






You can find the final EFI folder here

Link to comment
Share on other sites

Hello, here i have my EFI working with Big Sur. almost features working:

  • wifi: i use a tl-wn725n
  • bluetooth: not working yet
  • usb port: ok
  • hdmi: not tested yet
  • audio: ok
  • built-in camera: ok
  • touchpad: ok

if there is any fixes for bluetooth, please share here


my specs:

i5 4310m HD4600


320gb hdd


my efi here (also have mojave/clover and catalina/opencore)


contact me on fb: fb/kaotd

Link to comment
Share on other sites

No, IntelBluetooth kexts doesn't work with this card


I forgot that i was made some changes to the IOBluetoothFamily.kext

following this topic, without this patch, the bluetooth couldn't work properly

But with Big Sur there is some commands to make the changes to work:


- First, SIP must disabled

- Then download this (contains patched kext(grabbed from Big Sur 11.2.1) and the script i wrote for patching bluetooth)

- run 

cd Intel-N6235
sudo chmod a+x Intel-N6235_BigSur.command

and double-click the script to run, after script run completed, reboot


i'm still looking for a method to patch without editing kext, if you have any suggest, please ! Thanks


Screen Shot 2021-02-23 at 12.45.36.png

Link to comment
Share on other sites

  • Administrators

The only alternative to the kexts mod or FakeSMC injection (by far the best method to me) I can think of would be to apply an on-the-fly Info.plist patch for the target kext through your bootloader config. The patch would consists of replacing the vendor and device ids of an existing model entry by the Intel ones.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...