Jump to content

Dell Vostro 5568: macOS Catalina optimisation


Recommended Posts

Hello Everyone,

I joined today and installed macOS on My Dell Vostro 5568. It has i5-7200U + GeForce 940MX.

 

As a test, I did use @Syonagar's OpenCore Bootpack for Catalina (thanks for that). And as a surprise It did get installed successfully with the mentioned issues. However now I am not sure which EFI folder to copy into The EFI partition of the laptop. The given bootpack the EFI one or the one in MacOSX folder? So I have not yet mounted EFI partition and using usb drive to boot.

 

Other than that I also have two more known issues if anyone have any solution please provide.

 

1. Really Poor battery life I am getting 2-2.5hrs which is almost half or even less than half of windows.

2. A bit lower quality audio from Headphone Jack and Speakers. Also if this helps to figure out problem the headphone jack doesn't work when inserted full we need to pull it a bit out

 

Thank You for helping in Advance.

  • Like 1
Link to post
Share on other sites
  • Replies 81
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello Everyone, I joined today and installed macOS on My Dell Vostro 5568. It has i5-7200U + GeForce 940MX.   As a test, I did use @Syonagar's OpenCore Bootpack for Catalina (thanks for

Posted Images

  • Moderators

You should copy the EFI folder. The one in MacOSX is created when you open the folder in Windows. You can delete that.

As for battery life, make sure you have 940MX disabled. It's drains the battery and is not supported. It can be disabled with an SSDT-DGPU.aml or the similar.

Audio jack could be your hardware issue. Try different headset. For louder, you could try 3rd party app like Boom2 or look for another layout-id for you audio Codec.

Link to post
Share on other sites
  • Administrators

Hey @jantestmac

 

Great to hear that the bootpack is working for you.

 

As for the headphone jack, I suspect its due to it being both for headphone and mic i.e. a mobile handsfree kit could be used with with both speakers and mics working on windows.

 

Will need to look into this further.

 

Cheers!

Link to post
Share on other sites

@Jake Lo, Thank you for the reply I am just copying it now :).

For Battery i.e. 940MX,  how do i make sure it's disabled? I did use @Syonagar's bootpack and assumed he might have provided proper SSDT and I don't have a windows in this machine is there any way to compile SSDT in MacOS? Or any way to get prebuilt SSDT.?

 

For Audio:

I am pretty sure it's not hardware thing as I watched the opencore guide yesterday in windows Lol. Anyway It's not just about headphone jack the audio quality is also really poor on headsets.(I am not sure about speakers as I haven't heard them from nearly 7-8 months in windows too)

 

It's a bit hard to find right words but It kinda sounds like a bit faded or so. And when I turn the volume to full a lot of noise is there.

(This type of sound sometime comes from my dekstop when I accidentally pull out the headphone jack a bit from cpu so I thought it's cause of headphone jack but don't know exactly)

 

Any help will be appreciated :)

 

@Syonagar, Oh okay but As I mentioned in another post it's not really about headphone jack. I meant that even audio quality is really poor in headset. Kinda Faded sound comes (Like mono or something I am not sure about exact words) and when I turn the volume more than 70-80% there is too much noise.

 

Also as @Jake Lo Suggested have you disabled 940MX? Cause I am getting really poor battery life? Or if you haven't was it supposed to be done by me? If yes then how should I do it on MacOs as I don't have windows on this machine now?

 

Oh Also I an being a bit Paranoid about this EFI folder whether to copy it into EFI partition or not cause if any kext is wrong will I be able to change it if macOs don't boot??

 

Also thank you for the reply really appreciate it :)

Link to post
Share on other sites
  • Moderators

Looks like the Config has -wegnoegpu in bootArg, maybe it's not enough to disable the DGPU.

Try this, replace Config file and add SSDT* to ACPI folder, reboot

I also change the audio layout-id to 14, you currently have 11. See if it helps.

If not, you can try the following as well by changing it under DeviceProperties/Add/PciRoot(0x0)/Pci(0x1F,0x3)

13, 16 and 56 

 

5568_disableDGPU.zip

Link to post
Share on other sites

Yes I haven't done any changes to the bootpack which @Syonagar provided. Let me try replacing this in the EFI partition(Oh btw I finally mounted after you said to copy EFI Folder) 

 

EDIT:

So I copied that file in ACPI folder and Replaced config.plist from Zip in EFI Partition and restarted the laptop but now it's STUCK on a screen with apple LOGO with no progress bar.

And The Contents of EFI Partition Right now is All files from the Bootpack Along with the SSDT-* file you provided and the config.plist of bootpack is replaced with yours. Rest everything is same as that bootpack.

I also tried RESET NVRAM option from picker but no help

Link to post
Share on other sites

I did try out layout-id : 13, 16 and 56 all three of them is giving almost equal poor sound.

 

Though I should mention one thing while googling here and there I saw someone claiming that changing balance of headset(Under Sound Preferences) fixes sound I tried to Slide balance to ALL the way to R(Right) and to my surprise it does make a difference and the sound is a bit better but still its not fixed i.e. I am still getting a bit faded sound and noise when I increase the volume. 

 

Will changing VoodooHDA to AppleALC help? If so How Can I change my audio kext to AppleALC? To check If VooDooHDA is the problem I am really down to change that too cause the sound in headset is really poor? or is there anyother potential solution I should try.

Link to post
Share on other sites
  • Moderators

If you had already tested different layoutid's, it means you are already using AppleALC. 

Only way to fix is to learn to patch the audio yourself or fix what's already out there.

Here's an old guide but should still work.

Link to post
Share on other sites

How do I find out if I am using AppleALC as I checked the kext folder of bootpack from @Syonagar and there is VoodooHDA present. That's why I asked.

 

And also I managed to fix that apple Logo thingy by booting through USB with previous config file using proper tree to build the config file using snapshot of OC(with that SSDT-* in ACPI you provided) and replaced that in EFI partition. And it is booting up again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...