Jump to content

Dell Precision 7510: unable to get Intel HD 530 Graphics working


Recommended Posts

Newbie here. I've managed to go from knowing practically nothing about Macs on Thursday morning to having a sort of working Hackintosh by Friday evening, thanks to the awesome work of so many others documenting this process!

However, I've spent the entirety of Saturday trying to figure out the graphics. I'm stuck at "Display 8 MB" and cannot get the Intel graphics to be recognized. I feel like I've tried everything, but can get nothing to work. I'm sure I'm overlooking something simple and have probably missed several steps.


I started over with a clean install and added the iGPU properties per the OpenCore install guide (I think), but still can't get anywhere. Below are the system specs and attached is the EFI. Any help and direction is greatly appreciated!

Dell Precision 7510
Intel i7-6820HQ (Skylake)
Intel HD 530


Mojave 10.4.6

OC 0.6.6
OpenCore Configurator
Lilu (1.5.1) and WhateverGreen (1.4.7) kexts

Confused if id should be 1916 or 1619

AAPL,ig-platform-id = 00001916
device-id = 19160000
framebuffer-fbmem = 00009000
framebuffer-patch-enable = 01000000
framebuffer-stolenmem = 000030001


Link to comment
Share on other sites

  • Moderators

Your platform-id is in the wrong location for HD530

Add this instead


AAPL,ig-platform-id = 00001619
device-id = 16190000
framebuffer-fbmem = 00009000
framebuffer-patch-enable = 01000000
framebuffer-stolenmem = 00003001


You could try my files here

Make sure to have Switchable Graphics enabled in BIOS, UEFI enabled, AHCI enabled and secure boot disabled



  • Thanks 1
Link to comment
Share on other sites

  • Administrators

Values for DATA type properties are specified in reverse byte order and, usually, as WORDs of 32bits (i.e. 8 x hexadecimal characters).


If you look at the specs of your Intel i7-6820HQ CPU, you'll see that its HD530 iGPU carries id 0x191b. In order to obtain graphics acceleration on Skylake (SKL) HD530, you must:

  • changed iGPU id to 0x1916.
  • use layout 0x19160000

Since these values are injected as 32bit hexadecimal WORD in reverse byte order, you must use 16190000 and 00001619 respectively.


If you look at the other injected properties:

  • framebuffer-fbmem = 00009000
    • -> 00009000 equates to hex 0x00900000 which is 9437184 in decimal, i.e. 9*1024*1024 or 9MB
  • framebuffer-stolenmem = 00003001
    • -> 00003001 equates to hex 0x01300000 which is 19922944 in decimal, i.e. 19*1024*1024 or 19MB

You can read all about graphics framebuffers and injected properties in the WhateverGreen manual.


:excl: Be careful as -again- most DATA properties are entered as 32bit WORDs, i.e. 8 x hexadecimal characters. In that respect, the 9 x character value you posted for framebuffer-stolenmem (000030001) was incorrect but that was clearly just a typo since it was Ok in your config file.


The other important part you need to understand with regards to property injection is the location/device at/to which you apply the injection; it's the left part of the injection screen in tools such as Clover Configurator or OpenCore Configurator. This must be right or you may inject properties at the wrong place which may result in undesired side-effects and may lead to operating system crash/KP.


These locations are related to chipset and manufacturers choices of hardware implementation. For instance, in a laptop, the integrated GPU (iGPU) is always located at IO address 0x00020000 (or @2) and the discrete GPU (dGPU) is always located at IO address 0x00010000 (or @1). When you inject properties in your bootloader config, this is expressed as:

  • PciRoot(0x0)/Pci(0x1,0x0)
  • PciRoot(0x0)/Pci(0x2,0x0)

In the same respect, the audio controller is often found at IO address 0x001b0000 (or @1b); again this is expressed as:

  • PciRoot(0x0)/Pci(0x1b,0x0)

LAN card can often be found at 0x00190000 which is expressed as:

  • PciRoot(0x0)/Pci(0x19,0x0)

Sometimes, devices are located under secondary root bridges. This typically applies to hardware accessories such as SD card reader or wireless card; for instance you could find a card reader located at 0x0 under a root bridge located at address 0x001c0005 or a wireless card located at 0x0 under a root bridge located at address 0x001c0000; in such instances, this is expressed as:

  • PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0)
  • PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0)


To identify the location of any given device of the PCI bus (or in IO), you may use tools such as IORegistryExplorer, IOJones or other such as Hackintool, etc. Or you may open up your DSDT with tools such as MaciASL but this is a little more tricky and requires more computing knowledge.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Updated the platform location. Switchable graphics keeps disabling itself in the BIOS.


I forgot to mention that I also have an NVIDIA Quadra M1000M... minor detail = )

Looks like I need SSDT-Disable_DGPU.aml? I tried adding -wegnoegpu as a boot arg, but that didn't seem to work. Tried using the device properties method to disable, but that resulted in no boot and a reinstall.


Link to comment
Share on other sites

I've downloaded the files and copied the AMLs and kexts to my EFI. Does the hardware ID need to be updated in the disable GPU aml?

As far as switchable graphics, I am enabling them in BIOS (leaving discrete unchecked). It goes through the verbose, but restarts before getting to the Apple boot screen. It then completely boots. After restarting and going into BIOS, switchable graphics is disabled. So switchable graphics is getting disabled by something during boot.


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...