Jump to content

Enthusiast laptop: Getting UHD 620 working under Monterey (or Big Sur)?


Recommended Posts

Hi all-

I already posted a related question over at InsanelyMac, but it was suggested elsewhere that I should check here, in particular with @Jake Lo since he seems to knowledgeable about iGPUs and I've gotten great help here in the past too.


Anyway, I put the latest Coreboot on my X210, and have a (more or less) working Mojave install using OC 0.7.3. I then tried to duplicate the process to install Big Sur, but none of the frambuffer settings (or any that I can find so far) resulted in working acceleration. Out of curiosity, I tried the same thing with Monterey Beta 6 to see if anything would change, but it does not. I also updated OC to 0.7.4.


Since I overwrote the Big Sur install with the Monterey one, this question should apply to the latter.


As far as I can tell, my DVMT should already be at 64MB or higher (Coreboot guys tell me it's set to the max by default), and I don't need any stolenmem / fbmem lines for Mojave anyway.


I've attached my current EFI, in case there's something obviously wrong - I'd love to get some ideas that I haven't tried yet, since I've seen plenty of builds with my CPU/GPU that seem to work. All the ones I've found so far have IDs that do NOT work for me, however...







Link to comment
Share on other sites

This is wrong



Describe the specifications of your Lenovo, precise model CPU, if equipped with Discrete GPU (Nvidia or AMD) etc etc is detailed


The order of the kext this should be, and also ioreg, in my opinion things are missing to fix: trackpad as a minimum


it would be useful to extract ACPI and Log files with this EFI Debug 


EFI Debug 0.7.3.zip

Link to comment
Share on other sites

  • Administrators

I’m having difficulties finding the specs of this ThinkPad X210 model. By now, the old member that you are should know that providing one's platform specs is the 1st requirement to obtain support and assistance. So please do so before anything else.


This being said, given that you all you mentioned was UHD 620, we can only guess that your X210 is either:

  • 8th gen Kaby Lake R
  • 8th gen Whiskey Lake
  • 10th gen Comet Lake


 The iGPU properties that require to be injected differ according to your system’s CPU family. Given that you appear to fake the id of a Kaby Lake R iGPU (0x5916), I suspect your X210 is of that particular generation. For such Kaby Lake R platform, the following properties usually are required:

  • KBL framebuffer layout 0x59160009 or 0x591B0000
  • fake iGPU id 0x5916
  • SMBIOS MBP15,2


I invite you to consult the WhateverGreen User Manual. You'll find that the KBL framebuffer layout id you specified in your config does not exist which would explain a few things, wouldn't you say?


I also doubt you need the CpuTscSync kext.

Link to comment
Share on other sites


@Hervé I thought I have the information about the machine in my signature for the  exact reason of informing people thereof. Is it not visible? Please let me know... Apologies for that, I did not mean to annoy you. The specs of the machine, to the best of my knowledge, are as follows:


- 8th Gen Kaby Lake R i7-8650u

- Intel UHD 620 graphics

- Internal LCD connected via eDP

- miniDP port

- VGA port via ... internal eDP converter chip, I think. Unsure, but I can find out.

- Monterey is on a Foresee 128GB M.2 drive, which has a SATA interface (B+M key)

- 16GB RAM (have to look up the make/model, if relevant)

- AX200 WiFi (working fine with itlwm / bluetooth kexts, obviously not on Monterey yet though)


I've been through the WEG manual many times, and have tried every frambuffer listed for KBL-R. I am aware that the framebuffer currently present in the EFI I shared is invalid, as that is the only way I have managed to get the system to boot (any invalid one will do). I've tried the ID's you mentioned as well to no avail, and my SMBIOS is already a MBP 15,2 (according to your recommendation in my InsanelyMac thread). The SMBIOS alone did not seem to have made much of a difference.


@Baio77 See above, I know that the current ID was wrong - but couldn't get it to boot otherwise. Using your EFI, how should I extract the ACPI, and which log would you like to see? OC boot log?


@Syonagar Coreboot lets me do other fun things, like stick an entire Linux distribution into the ROM (Check out Tinycore Linux!). The Chromebook people actually also have the same problem I have, as they use a variant of Coreboot by default - you might consider this question an aggregation of at least two other folks who can't get this to work either, but the Chromebook + Hackintosh intersection is pretty small. There's a Discord server for it, if you're interested.


Apologies again for apparently missing information, I am not ignorant of the need for it and thought it is already present in my signature. Please let me know what other information I can provide that might be useful here.



Link to comment
Share on other sites

  • Administrators

Signature is now visible but it was not before.


On checking things out on the Net, I now understand why I could not find any specs or info about a ThinkPad X210... That simply does not exist! The computer in question here is not a real Lenovo ThinkPad at all but something made & sold by a Chinese group of enthusiats that goes by the name of 51NB and who re-use ThinkPad shells to fit their own motherboards or provide motherboards to fit into Thinkpad shells. :D Coreboot firmware in place of a standard/stock BIOS... why not?



I'm not saying the machine is bad but this belongs more to the DIY classification than anything else. Bearing this in mind + the fact the BIOS current firmware fitted to the motherboard is not what we would call usual standard, I would not expect too much in terms of chances to fully or properly run macOS on this platform. Too many unknowns (but one must love the unusual 2880x1920 LCD panel) and, as you experienced yourself, the usual Hackintosh settings just don't work.


PS: I took the liberty of modifying your signature + thread title because we don't want to mislead anyone with this... "ThinkPad".

  • Thanks 1
Link to comment
Share on other sites

  • Create New...