Jump to content

Optiplex 5040 SFF - Big Sur 11.1: 2 monitors DP+HDMI fail


AudioLab
 Share

Go to solution Solved by Jake Lo,

Recommended Posts

Hello everyone. I apologize if I post a thread that surely finds thousands of answers but I really need your help. I own the pc described with Big-Sur installed. I can't get 2 monitors to work together. Either one goes to hdmi port or the other to Displayport. I tried looking at the guide for port and frame buffer patching. But I didn't understand much about it. All in all, when I modify the config.plist, any entry even one, I get the annoying OC error: 0 failed to load driver (something like that) at startup.

Is there any good soul here who can help me understand or modify the config.plist to make my 2 monitors work together again? I share the efi.zip file in the meantime. A thousand thanks. (Modificato)Ripristina originale

EFI.zip

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

  • Moderators

Any other version shows as corrupted when I open it with 2.1. 

It opens if I use version 3.0+ but it doesn't look right. If you look at x86PlatformPlugin, on the right when you expand CPUStates, you'll see all zero's. With 2.1, it'll be in numbers.

Anyway, it's my preference. 

Looking at your IOReg file, I only see 1 display connected to port 6. Is this the HDMI or DP display?

Maybe attach one IOReg for each display connected so to determine which port is use for each display type.

Just notice your EFI folder has no Config.plist

Link to comment
Share on other sites

 

Ok Jake, attached under the 3 Ioreg made with version 2.1. Each with only one connected display. The strange thing is that when I connect the monitor to DP2 there is no output on the screen and

connection with remote app like Anydesk, reports the monitor as integrated, Apple monitor, the system is reported by SMBIOS as IMac 17.1.

Now in my efi folder there is a Config.plist file inside the archive.

I hope everything is okay and can help for me. Thanks a lot.

 

efi fiolder.zip Ioreg HDMI port.zip ioreg dp port 1.zip Ioreg dp port 2.zip

Link to comment
Share on other sites

I have tried but no luck. It boots into recovery OS and usb stop working. I have made a bootable usb pendrive using gibMACOs...then copy EFI Folder inside and replace config.plist with one you linked. Changing displayport I get only blank and black screen. There is some settings I must look at?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...