Jump to content

E5470: no wireless, bluetooth and trackpad after Big Sur update


Bu Yezi
 Share

Recommended Posts

@Bronxteck I replaced the entire EFI folder, from my past experience you guys asked me to replace the EFI folder. I followed the same. 😕

@Jake Lo I didn't know the ways around replacing the plist file without booting into OS and mounting the EFI. So I reinstalled Big Sur with same old guide and EFI folder (downloaded in August) all over again. Track pad, Bluetooth, Wifi are not working. I'm thinking, can I update to Monterey and try fixing the BT, Wifi & trackpad? Monterey runs well on E5470?

Action plan:
> Update OS.

> Update to latest OC configurator.

> Use the EFI folder you have provided above.
Will it work?
 

Link to comment
Share on other sites

  • Moderators

You shouldn't have to re-install if it fails to reboot, just have to fix the EFI boot back. You should always have a backup bootable USB handy.

Just format a USB drive (all it need is 256 mb), you can use an SD Card too. Format to Fat32 and place the whole EFI folder on the root.

You have LauncherOption set to Full on your original file, so I think it create a boot option in your BIOS call OpenCore. 

Try going into your BIOS and remove that boot option.

As stated the files should work for Monterey, if you like create a new installer for Monterey and use that bootpack.

  • Like 1
Link to comment
Share on other sites

Now I realized that was a stupid move to reinstall the Big Sur again. I fact, I had the Big Sur USB stick previously used. I should have booted into the machine and replaced the EFI folder from my EFI backup. Anyway, no point talking...

I'm installing Monterey now. Made USB stick for Monterey using createinstallermedia command, EFI partition mounted using opencore configurator and I ejected EFI partition by mistake thinking it was System EFI.

 

Now I'm trying to mount the EFI partition of the USB again. Opencore configurator is not recognizing EFI partition of the USB stick, MountEFI tool says there's no partition associated with the disk.

Any solution for this? Please help!

Screen Shot 2021-11-25 at 3.33.37 AM.png

Screen Shot 2021-11-25 at 3.35.52 AM.png

Screen Shot 2021-11-25 at 3.36.42 AM.png

Link to comment
Share on other sites

  • Administrators

EFI partitions do not exist by default on a raw/reinitialised USB key. It usually is created by bootloaders such as Clover (or older bootloaders before). Since you do not have any EFI partition on the device, you may manually create it and format it FAT32. Or, if you find the associated process not within your grasp, install Clover temporarily on the USB key. Once you wipe out the contents of the EFI partition created by the Clover installer, you'll have an empty EFI partition to play with.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...