Jump to content

ALPS Touchpad driver with VoodooInput


Recommended Posts

Thanks for the logs again.


Found a very weird issue:



VoodooInput gets the wrong trackpad size. As seen on top, the left log shows the correct resolution, which is 1536. However, the right log which is the broken trackpad has negative resolution.


In addition, this does not look correct either.

VoodooInput: ALPS: transducer->currentCoordinates.y: -943
VoodooInput: ALPS: transducer->currentCoordinates.y * 1.0f: -2147483648


-943 * 1.0 is not -2147483648


The working log in comparison:

VoodooInput: ALPS: transducer->currentCoodinates.y: 779
VoodooInput: ALPS: transducer->currentCoordinates.y * 1.0f: 779



@Jake Lo


Can you try this kext?


I have disabled code that changes the dimensions in runtime.


Link to comment
Share on other sites

hello, first i want to ask how do i know the version of alps v7 or v8 or something else?


I have a PS2 ALPS trackpad (Notebook Fujitsu A574) so far trackpad works using VoodooPS2Controller with ActLikeTrackpad emulation on Voodoops2mouse.kext (without it the trackpad doesn't work/not detect), I've tried several other ALPS kexts but they weren't detected my trackpad, today I found this tread and try it, at least with this kext trakpad is detected😊but not responsive

Link to comment
Share on other sites

If the trackpad gets detected, run IOReg and scroll down to PS2M and there should be an ALPS entry. Click on that and on the right side there should be 'ALPS Version'. Tell what is the value there.


It would be better if you could send the IOReg and logs (run this command in Terminal: sudo dmesg > alps.log) to diagnose the issue 

Link to comment
Share on other sites

  • Moderators


is there a way to slow down the track stick speed a bit more?

I tried setting in mouse preference but it's not perfect. When I tried to move to a text or a file with the track stick, it'll always miss the target. It'll take several tries before it'll get to the target. Hope that makes sense.

Also it seems to be draining a lot of battery life. It drains a lot faster than the other voodoo kext. I'm switching back to acidanthera's for now to confirm.

Link to comment
Share on other sites

Currently, it is divided by 2 (half speed). Below are kexts that are divided by 3 and 4. Whatever you like, I will push it to the repo.


VoodooPS2Controller-1.0.6-DEBUG (divided by 3).zip


VoodooPS2Controller-1.0.6-DEBUG (divided by 4).zip


For me, the battery drain is almost the same. Might be because there is an actual MT2 emulator instead of a standard mouse, which does not need a lot of processing. Also, if you are using the Debug version of the kext, it will affect the system and battery life too, as it creates logs every time a finger is on the trackpad.



BTW: The kexts also have all the changes I did in the last few days, including Force Touch support. To enable Force Touch, one does need to set ALPSForceFT to 1 and ForceTouchMode to 2 (Info.plist of VoodooPS2Trackpad). In FingerMgmt, you should see the input getting bigger if you press hard. One could also confirm if the look-up feature works.

Link to comment
Share on other sites

  • Moderators

tested both versions. They both work just about the same so let go with divisible by 3. 

force touch works after editing the trackpad kext but it's harder to zoom in so I changed it back.

can you compile a release version with divided by 3?

the debug version is really draining the battery and the fan is going wild.

Thanks for the awesome kext and support.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...