Jump to content

Lenovo Y520: SD Card Reader and sleep don't work


Recommended Posts

I almost finished the hackintosh of Lenovo Y520 with OC in MacOS Monterey.

There are two features not working including O2 SD Card Reader and sleep-black screen.

Wifi and BT are working with Broadcom 94360NG, air-drop and hand-off OK.

Patch the SSDT-SDCard.aml or define the Device Property is the same result, that only show the SDCard Reader is detected but without AppleSDXC.kext.

In the Kernel patched AppleSDXC.kext and AppleSDXCInjector.kext are not work.

I try to block, Force or patch is still no work.

In the original AppleSDXC I find the IONameMatch pci17a0,9755 and pci14e4,16bc, as I change the compatible to pci17a0,9755, macOS system report show the device driver is on but actuarially is block by the sub driver of AppleSDXCBlockStorageDevice.

Here are the attched files as below,

Could you help me to verify the problem and thank you very much.

截圖 2022-06-23 下午6.23.42.png

截圖 2022-06-23 下午6.27.59.png

ACPI_SSDT.zip configOC.plist.zip DSDT.aml.zip MacBook Pro.ioreg.zip

Link to comment
Share on other sites

  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

the xprw can not fix sleep issue, mouse and keybord seems no work after sleep

enable the aspi of Change _OSI to XOSI and replace the  subsystem-vendor-id same as Broadcom wifi

is still no work

i have to add the patch of SSDT-SDCard.aml in order to get the reulit as below (deteted and no driver on)

截圖 2022-06-23 下午6.23.42.png

Link to comment
Share on other sites

Crad reader is nothing

Could we try to add the PR02.SDXC into the patch of SSDT-Y520.aml

Device (SDXC)

{        

Name (_ADR, Zero)  // _ADR: Address        

Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake

        {                

Return (GPRW (0x69, 0x04)) }        

Method (_RMV, 0, NotSerialized)        

{                 Return (0x00)        

}

}

 

**the Return (GPRW (0x69, 0x04))   need to check 0x69, 0x04 is correct

 

I try to add but i have no idea compile

 

I just want to chang the PR02 PXSX to SDXC, befor the code of  Device (SDXC) should add Device(PR02)

sorry i am a new guide and no skill of any computer language

 

截圖 2022-06-26 上午10.40.48.png

截圖 2022-06-26 上午10.39.29.png

 

 

 

Link to comment
Share on other sites

Hi, I have had a look at the files and it seems to me that the base of this EFI is very obsolete, surely it has been converted by Clover. ACPI files are old fashioned. So I started the ACPI thanks to the DSDT posted, so a Test of my EFI + ioreg is missing. This is just the starting point as it probably needs adequate \ improved things, like the trackpad probably can be improved, I just need your cooperation.
https://drive.google.com/drive/folders/1i-_ME1LBNFuOsPXdeahQnO22umdzCo82?usp=sharing Test this in USB , if start ioreg .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...