Jump to content

Dell Optiplex 3050 microFF: help with dual display at startup


naquiyankee
 Share

Recommended Posts

Hi there! I think I could use some help here. 
I just installed macOS Monterrey on my Dell Optiplex 3050 microFF. I am using dual monitors through DP and HDMI ports, however, at startup, the monitor hooked up to DP works, the HDMI doesn't, I need to unplug the HDMI and plug it back to make it work.
I am just a beginner and followed the dortania guide. I was trying to patch the connectors, but to be honest, I am a little confused and I don't understand it. I would like to be able to use both monitors without unpluging and pluging back. I attach a screenshot of my config.plist and IOREgistry explorer.

 

Screen Shot 2022-11-26 at 22.18.26.png

 

Screen Shot 2022-11-26 at 22.18.43.png

 

Screen Shot 2022-11-26 at 22.20.03.png

 

Screen Shot 2022-11-26 at 22.20.44.png

Link to comment
Share on other sites

  • Administrators

You use SKL framebuffer atout 0x19120000 which defines the following properties:

ID: 19120000, STOLEN: 34 MB, FBMEM: 21 MB, VRAM: 1536 MB, Flags: 0x0000110F
TOTAL STOLEN: 56 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 124 MB, MAX OVERALL: 125 MB (131608576 bytes)
Model name: Intel HD Graphics SKL CRB
Camellia: CamelliaDisabled (0), Freq: 1388 Hz, FreqMax: 1388 Hz
Mobile: 1, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[255] busId: 0x00, pipe: 0, type: 0x00000001, flags: 0x00000020 - ConnectorDummy
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x00000187 - ConnectorDP
[2] busId: 0x04, pipe: 10, type: 0x00000400, flags: 0x00000187 - ConnectorDP
FF000000 01000000 20000000
01050900 00040000 87010000
02040A00 00040000 87010000

 

As suggested by Jake, once you've identified in IOReg which connector your HDMI output attaches to (in all likelihood con1, [email protected] but it may be con2, i.e [email protected]), patch its type by adding the following lines to your injected iGPU properties set:

framebuffer-conX-enable    1           NUMBER
framebuffer-conX-type      00080000    DATA

where X is 1 or 2.

 

HDMI output can also be a little difficult at times on Skylake HD5x0. Make sure to add Whatevergreen boot arg igfxonln=1 in your bootloader config.

 

See the Whatevergren documentation and user manual.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...