Jump to content
PayPal donations: [email protected] ×
EMlyDinEsH

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)

Recommended Posts

@andrey1970

 

And how can i do this?

Is it, edit those info.plist file inside the kext?

Can you give the guide, thanks for your help

 

-- edit --

 

ok, I've edited info.plist file and now it works as supposed

thank you for your help

 

btw, more gestures as shown in the preferences is not really working

or, are they being worked on?

Ok, it works, thank you

Share this post


Link to post
Share on other sites

Hi

 

my computer has a ps2 touchpad (sony vaio f11)

It is under PNP0303/ .  The version is from Nov 2016.

 

The driver works, but the following doesnt work:

 

- After boot up, I always have to enter the prefs pane one time, to enable dragging (just opening it is enough)

- Double tap on the pad for right click doesnt work

- Scrolling only works if I hold down Ctrl. So not only on pad. The original functionality had a small scroll border on the right. That is gone.

 

Any idea how to fix any of this problems?

Share this post


Link to post
Share on other sites

 

I managed to get everything working almost perfect on Lenovo Thinkpad L420, all because i decreased the pressure necessary for tappping and dragging, I am running on Synaptics 7.2.. The only things that still dont work are the trackpoint (little red ball on keyboard) and sometimes the trackpad simply crashes and stops working, leaving only the keyboard enabled. This happens specially after sleep. Rest is great, except for a few things that could be improved, but i would love if you could perfect these issues in your next beta ( by the way, most of the items present in the Sierra trackpad prefpane dont work), can we make a debug session mate, like you offered me before?

Share this post


Link to post
Share on other sites

Hi! 
First of all, thank you for the amazing work. First time Hackintosher.

Tho, I have one problem. I'm trying to get my Trackpad for my Acer 5750G (Elan) to work.

I downloaded 4.6.5 and my keyboard is working, but my Trackpad is not. 
Before your driver the Trackpad system settings said "Found no trackpad" (or equivalent) but now it shows nothing.

I used Clover to install 10.12.3 Sierra. Got everything to work except the trackpad and it's driving me nuts.

My ApplePS2Controller.kext was placed in my EFI/Clover folders, I removed it and first tried installing your driver in the same folder but that gave me the same result as putting it in S/L/E.

Am I missing something?

 

 

EDIT:

 

Do I feel dumb...
I had the trackpad turned of from my keyboard shortcuts... So, it works. I can scroll, click and move.
But that's it. I am really happy tho, but still can't access the settings from System Preferences, Trackpad tab is still blank. 
Any solution to this yet? I've seen some workaround but for older OS's. And I don't dare mess with those now that I got everything working.

Thanks yet again!

Share this post


Link to post
Share on other sites

On MacOS 10.12.3, using last beta kext's trackpad. It works as it has to (scroll with 2 fingers, double fingers tap -> right click...) except two fingers back/forward on web browsers. Plus, first time I go to trackpad prefpane it shows up, but back to prefpane does not show anything.

  • Like 1

Share this post


Link to post
Share on other sites

download ioio and copy it to the system folder and run this:

ioio -s ApplePS2SmartTouchpad Clicking 1

ioio -s ApplePS2SmartTouchpad Dragging 1
ioio -s ApplePS2SmartTouchpad TrackpadRightClick 1
ioio -s ApplePS2SmartTouchpad DragLock 0
ioio -s ApplePS2SmartTouchpad DragExitDelayTime 0
 
 
ioio -s ApplePS2SmartTouchpad EdgeSwipes 0
 
 
then you can use tap 2 fingers for right click

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...