Jump to content
macdelld830

Latitude E5530

Recommended Posts

I have an E5530 (since DEC 2012) and would like to know from Newbie how the installation with the new DSDT went. I have an I5 machine, 8GB, an Apple compatible WiFi card (which I pulled from my D830 where it worked perfectly). So far I installed using MyHack and the generic Extra folder, but can only work in safe mode. Tried the same with Uniboot (chameleon, stolen and rebranded) with the same result (can ony start in safemode).

 

The steps to get to a full normal boot elude me, can anyone just list them, and please clarify where to get the necessary files please (do not just name them, since I have no idea where you got them from)?

Share this post


Link to post
Share on other sites

This is not like crossing a wooden bridge over a tiny stream... There is no such thing as standard Hackintosh installation.

 

You need to start listing your entire hardware specs, clearly identifiying all major pieces of hardware that make up your system. Then you can look up for potential Mac OS support:

- CPU

- chipset

- audio

- video

- networking (wireless, bluetooth, LAN, etc.)

- trackpad

- keyboard

- etc.

 

Sometimes, the hardware will elude you, in which case you might have to inspect the Windows drivers to obtain hardware device id, which you can then lookup on the web for proper identification.

 

Your BIOS revision and settings will also need to be looked into and possibly adjusted. It's always recommended to run latest available BIOS.

 

Naturally, forum members shoud be able to help you once they see your hardware list, but without it.....

Share this post


Link to post
Share on other sites

Hardware should be nearly the same as the e5430. I too was only able to boot into safe mode at first, though I am past that now. I am trying to remember/record the steps I have taken to get where I am at right now, but I have been very busy and havent had as much time for this project as I would have liked.

 

I believe 10.8 I was able to get booted without safe mode, but 10.8.2 would not. I would need to double check that.

Update to the latest chameleon to get a more reliable boot.

Look at the kext list  that gohmac listed in the e5430 list, and use the voodooPS2Controller.kext attached in post # 12. Thats all I can suggest for now until I can get more of my issues fixed, verified, and documented.

 

Mark

Share this post


Link to post
Share on other sites

hi there,

 

here is a run down of my system:

 

It has an SD card slot as well as a PCIExpress cardslot. HDMI and two USB3 slots on the left, one USB2 in the back and one USB2 on the right of the housing. Webcam is built in. NO fingerscanner.

 

 

Model Latitude E5530 non-vPro
Processor Intel® Core i5-3320M CPU @ 2.60GHz, 2601 MHz, 2 core('s), 4 logical processor(s)
BIOS-versie/datum Dell Inc. A07, 8/10/2012
SMBIOS-version 2.7
 
DVD-player: TSSTcorp DVD+-RW SN-208BB ATA Device
PNP-apparaat-id IDE\CDROMTSSTCORP_DVD+-RW_SN-208BB_______________D500____\5&1FDFF4BA&0&1.0.0
 
Audio: IDT High Definition Audio CODEC
PNP-apparaat-id HDAUDIO\FUNC_01&VEN_111D&DEV_76DF&SUBSYS_1028053D&REV_1002\4&282DA20&0&0001
 
Bluetooth-audio
PNP-apparaat-id BTHENUM\{24DF01A9-3E4F-4C9F-9F66-5AA8AB14F8F4}_LOCALMFG&0000\8&2525F300&0&000000000000_00000000
 
Videocard: Naam Intel® HD Graphics 4000 - 2GB memory, - screen resolution: 1920 x 1080 x 32 @ 59 Hz
Standard-PS/2-keyboard (QWERTY)
Logitech HID-compliant Unifying Mouse
Network (wired): Producttype Broadcom NetXtreme Gigabit Ethernet
Network (wireless) - 2 cards installed:
Dell 1490 Dual Band WLAN-Mini-kaart
Intel® Centrino® Advanced-N 6205
Disk: Model Samsung SSD 840 PRO Series ATA Device, 238,47 GB (256.052.966.400 bytes), two partitions: one for Windows 7 - 64bit, the other reserved for OSX
Standard AHCI 1.0 Serial ATA Controller
Intel® USB 3.0 uitbreidbare hostcontroller PCI\VEN_8086&DEV_1E31&SUBSYS_053D1028&REV_04\3&11583659&0&A0
 
 
Any advice on the correct KEXTs is welcome. I'm more then willing to do tests and use this machine as a testbed.
 
I still have access to my D830 wich is fully working under 10.8.2 (still need to update to 10.8.3).
 
I want to try to get an external disk to boot fully, before I install OSX on the free partition on the SSD for a dual boot (Win7/OSX) system.
 
The EDP package for the E5430 will probably not work, as I do not have an I7 processor, but this is probably the closest base for my system, so I will try that this weekend.
 
 
Gert
 

Share this post


Link to post
Share on other sites

hello all,

 

I'm glad to say that I managed to get OSX 10.8.4 running on my 5530 using an external USB disk. So far it looks like I have

 

Graphics (with translucent menu bar, so I'm guessing I have accellerated graphics)

Sound

Mouse (I use a logitech Anywhere MX and the little stub in the USB port on the back)

Built in ethernet

Wireless (thanks to an old card by DELL)

 

I have not tested:

sleep, but shutdown works properly (and I do not use Sleep anayway)

SDHC

HDMI output or any second screen option.

 

For my graphics to work I needed to add a rather long string to the bootp file. Details of that file in a next message.

Share this post


Link to post
Share on other sites

hi iMick,

 

I consider my hackintosh incomplete. I can send you the Extra folder as it is now, but I do not yet have a good measurement on the battery, Speedstepping is not functional I think, Sleep is not tested, USB3 is not tested, HDMI out or VGA out is not tested, the SD card reader or Expres card slot (I have a QUERTY version without Smartcard reader but with Expresscard slot) are not tested yet.

 

I'm wrting this from my 5530 as a PC, I will send the Extra folder when I switch to OSX.

 

Gert

Share this post


Link to post
Share on other sites

Extra.zip

 

As promised, the Extra folder (zipped) from my OSX installation.

Point to note is that I have a QUERTY equipped 5530, no firewire port, Full HD display, no trackpoint, no fingerprint reader, no backlit keyboard.

 

Gert

Share this post


Link to post
Share on other sites

My Latitude E5530 with full HD screen (1920x1080) and i5 (3320M), 8GB RAM and SSD (250GB) is now on 10.8.5

 

Ethernet and wireless are working, full graphics accelerated, wireless via a Broadcom card,

 

Bluetooth is not working anymore, sounds is either full or none but buttons work (just the soundlevel does not change).

 

Gert

Share this post


Link to post
Share on other sites

Apple changed IOBluetoothFamily kext in 10.8.5 again (made it very much like in Mavericks) so you'll probably need to patch the kext to recover Bluetooth. They've basically added a new PlugIn (whose name eludes me right now) that seems to overwrite individual manufacturer's kexts (eg: CSR) and that appears to kill off most Bluetooth adapters. However, if you patch the appropriate PlugIn kext with your hardware PCI ids, you should get BT services again. I helped Leon that way after he updated one of his laptops to ML 10.8.5 last week.

 

For audio, try to switch to VoodooHDA if you have not already done so. Again, audio loss or trouble is being repeatedly reported by Hackintosh users after updating to 10.8.5.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...