Jump to content

Need help with D830 (x3100) with 10.7.4 PLEASE !


joot
 Share

Recommended Posts

Hello,

 

I need help with post installation of my Dell D830 (x3100).  But first I want to say thanks to this site for all the great instructions to get my Dell D830 (x3100) going thus far.  However,  I am experiencing a problem with the post installations with popup error message.  Here are some info:

 

Dell D830 (x3100)

10.7.4 installed with myHack

No EDP

 

The problem is that the computer would go into a panic mode where I need to restart the computer.  This would happen randomly 5 minutes into using it, other times 30 minutes into using it.   Always the same popup that says I need to restart the computer.  Really annoying.  Can someone help me ?  

 

Here's a screenshot of the problem:

 

8537073834_5bea572f14_b.jpg

Link to comment
Share on other sites

  • Administrators

I assume you installed with the bootpack, right?

 

What kexts do you have in /Extra/Extensions, if anything at all?

What parameters do you have in your Chameleon boot plist?

What SMBIOS profile do you use?

 

Is there a particular reason why you would not complete your setup with EDP?

Link to comment
Share on other sites

I installed with myHack on a USB thumb drive.

 

I have the following in my /Extra/Extensions folder:

 

 

AppleACPIPlatform.kext
AppleACPIPS2Nub.kext
AppleHDA.kext
AppleIntelIntegratedFramebuffer.kext
ApplePS2Controller.kext
BCM5722D.kext
FakeSMC.kext
FakeSTAC9205.kext
IO80211Family.kext
lspcidrv.kext
Patched_10.7_AppleRTC.kext
VoodooTSCSync.kext
 
Here's what is in my chameleon boot list:
 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>V -V</string>
<key>SystemType</key>
<string>2</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>10</string>
<key>USBBusFix</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>arch</key>
<string>i386</string>
</dict>
</plist>
 
 
Here's my SMBIOS:
 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMUUID</key>
<string></string>
<key>SMbiosdate</key>
<string>05/05/09</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MBP51.88Z.007E.B05.0905051508</string>
<key>SMboardmanufacturer</key>
<string>Apple Computer, Inc.</string>
<key>SMboardproduct</key>
<string>Mac-F42D86C8</string>
<key>SMfamily</key>
<string>MacBookPro</string>
<key>SMmanufacturer</key>
<string>Apple Inc.</string>
<key>SMmemmanufacturer</key>
<string>Apple Computer Inc.</string>
<key>SMproductname</key>
<string>MacBookPro5,1</string>
<key>SMserial</key>
<string>5W4ZPC123</string>
<key>SMsystemversion</key>
<string>1.0</string>
<key>SMmemspeed</key>
<string>800</string>
<key>SMmaximalclock</key>
<string>2200</string>  
  </dict>
</plist>
 
 
EDP was giving me lots of headaches.  I initially tried it and the system would not boot, keep getting stuck with black screen.  I found that the dsdt.aml file was the culprit.  So I end up using a different dsdt.aml file from somewhere else, then it booted fine and I was able to complete the installation.  Audio and wireless works good...just keep getting that pop up error all the time randomly...
 
 
 
Link to comment
Share on other sites

  • Administrators

The issue of black screen after EDP System Build should now be fixed (verified on D830 nVidia earlier on). Could you download and install a fresh copy or do an update? Then proceed with a new system build.

 

I believe you have the right kexts in /E/E, although I was not expecting the AppleIntelIntegratedFramebuffer kext... Have you tried to run without this kext in /E/E?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...