Jump to content

e6430 with NVS5200/Intel HD 4000


gouki

Recommended Posts

I am wondering this as well... 

 

leppy700m, it looks like we have pretty similar setups.  

Have you figured out how to get sleep working?

I used the files from Jake Lo's tutorial and replaced my wifi card with the one he recomended and it works great.

 

I have a docking station, but I don't get any video out of the DVI ports.  the USB ports work I think... but I did have to roll back the kexts to the USB2 ones.

 

No, i think the DSDT edit is a pretty good start, but it needs some fine tuning for reliable sleep.   DIsplay sleep seems to work fine here, but not full sleep.

 

RE monitors out from the docking station - that could be done in DSDT as well, or with some efi strings.  I don't have the time for these things that I used to.

Link to comment
Share on other sites

Good news!

Got USB 3.0 Superspeed working without system hang and no need to roll back to USB 2.0.

Get file here.

 

THANKS JAKE!

I will test this out later today!

 

And Thanks Leppy700m  I will look into fine tuning my DSDT and see what I can come up with, I don't have a whole lot of time either. :)

Link to comment
Share on other sites

We have added this system to EDP also!<br /><br />Could be worth the try! :)

 

I have just tried installing EDP and was impressed so far, what a great idea!  I think it fixed a few problems I was having (I was using a wrong DSDT and SDT.aml or whatever), but it also messed my sound and trackpad and a few other things up as well.  I just had to put back the kexts I was using for my system from this page https://osxlatitude.com/index.php?/topic/2327-dell-latitude-e6430/ that Jake Lo put together.

 

With Jake Lo's packages I was able to get everything working except sleep and HDMI out.

 

After installing EDP HDMI out works!  Actually, it works awesome!  See photos below :)

 

IMG_0215.JPG

 

IMG_0216.JPG

 

IMG_0217.JPG

 

Screen sleep no longer works fine like it used to, it just goes to a white screen...

See photo below (furthest to the right)

IMG_0219.JPG,And full sleep crashes the system entirely and needs to be rebooted, so I set the computer to never sleep for now.  most of the time its plugged in anyways, but It would be great if someone could come up with a sleep solution by editing the DSDT.

 

I haven't tested the docking station yet, but will on monday... it most likely will need to be fixed by editing the DSDT as well, but who knows!

 

Thanks!

Link to comment
Share on other sites

Here are the Kexts I am using in my Extras/Extensions folder:

IMG_0220.png

And here is a link to my extras folder if anyone has the same computer as me:

http://www.mastermindesigns.com/mastermindesigns/images/latitude-e6430/Extra.zip

 

Download, unzip, replace your extras folder with mine and run "myfix"

 

I figured out how to at least get my display to go black when the screen sleeps by editing the org.chameleon.Boot.plist like so:

IMG_0221.png

Here is a link to download my org.chamelon.Boot.plist file:

http://www.mastermindesigns.com/mastermindesigns/images/latitude-e6430/org.chamelon.Boot.plist

 

I believe what made it work was the "darkwake" Kernel flag :)

 

Can someone help with trying to get full sleep and the Dell Dock station working?  THAT WOULD BE SO AWESOME!

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...